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Chapter 1

System Setup

This chapter covers steps necessary to set up a 
new Digitizer EXjr system on your PC. You will 
also need to connect peripheral devices for use 
with Digitizer EXjr including, of course, your 
embroidery machine. Different devices are set up 
in different ways – some in Windows, via the 
Control Panel, others within Digitizer EXjr itself. 
For instructions on connecting devices to your 
computer and setting up in Windows, see the 
documentation for the device as well as your 
Microsoft Windows documentation.

Installation checklist

Use the following as a checklist of all necessary 
steps to follow when installing and configuring your 
new Digitizer EXjr.

 Step 1: Make sure your system meets the 
minimum requirements. See System requirements 
for Digitizer EXjr for details.

 Step 2: When installing Digitizer EXjr, read 
through all necessary installation steps carefully 
before getting started.

 Step 3: When the installation is complete, you 
will be prompted to restart your computer.

 Step 4: Attach your security dongle only when 
prompted. If you have an existing version of the 
software and have been provided with a new 
‘upgrade dongle’, attach your old dongle as well. 
See System security for details.

 Step 5: Connect your machine to the PC. See 
Supported machine models and memory cards for 
details.

 Step 6: If you are a new user, read carefully 
through the introductory chapters in the Onscreen 
Manual provided with your Digitizer EXjr 
installation pack.

 Step 7: Both new and existing users should 
read through the onscreen Release Notes for an 
understanding of new and improved features in 
this software release. You can access the onscreen 
Release Notes through the Help menu of your 
Digitizer EXjr installation.

System requirements for 
Digitizer EXjr

To install Digitizer EXjr on your computer, it must 
meet the following system requirements:
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Warning  You need to log on with Administrator level 
rights in order to install the software.

Adobe Acrobat Reader
In addition to Digitizer EXjr, you will require a 
recent version of Adobe Acrobat Reader. If not 
already installed on your system, this can be 
downloaded from the Adobe website.

System security

Digitizer EXjr is controlled by a security device or 
‘dongle’ attached to the computer. The software 

will not work properly if the dongle is unplugged 
from the computer while Digitizer EXjr is open. In 
this event, the application may hang or crash and 
any open files may be corrupted.

Digitizer EXjr Full Kit is shipped with a USB security 
dongle. Each dongle has a unique serial number 
and identity code so your system can be uniquely 
recognized. The security device plugs into a USB 
port on your computer. If your computer does not 
have a USB port, you will need to install a USB 
card. Parallel port dongles are not supported.

Warning  The dongle is the most important and 
valuable part of your system and should be treated 
with care. Always store it in a safe place when not 
in use. The dongle is guaranteed against defects in 
material and workmanship – under normal use and 
service when properly installed – for a period of 90 
days from the date of delivery. If it is faulty, it may 
be exchanged. If it is physically damaged, return it 
to your distributor and a replacement can be 
purchased. However, in case of loss or theft, you 
will need to purchase an entire Digitizer EXjr 
replacement system. For this reason, you should 
consider insuring your dongle.

Modifying an existing Digitizer EXjr 
installation

Whether you are updating your current 
Digitizer EXjr or wanting to uninstall it, you follow 
the same procedure. When you run the installation 
program again, it will automatically detect if there 
is an existing copy of Digitizer EXjr on your system 

Component Recommended
CPU 2 GHz + Latest Intel or AMD 32-bit (x86) 

or 64-bit (x64) multicore processor
Operating 
System

Microsoft® Windows® 7 with latest 
service packs installed (32-bit or 64-bit 
editions)

Internet 
Browser

† I.E. 8.0 or higher

Memory 
(RAM)

2 GB (more if running multiple 
applications)

Hard Drive 80 GB or higher
Free Disk 
Space

At least 20GB after installation

Monitor Dual monitors capable of displaying 
1280 X 1024 or higher

Graphics 
Card

Support for DirectX 9 graphics with:
WDDM driver
512MB or higher of graphics memory 
(non-integrated)
Pixel Shader 2.0 in hardware
32 bits per pixel
Dual monitor capable

Data drives DVD-ROM drive for software 
installation
Dual layer DVD-ROM for Extras DVD

Scanner, 
Printer, 
Plotter 
Connection

Windows-compatible (any connection 
method – e.g. parallel, USB)

USB port Dedicated USB port for a USB dongle
Mouse PS/2 or USB

† Internet connection required by certain parts of the system as 
well as for access to product information and online support.

http://www.adobe.com/reader
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and give you to option to modify, repair or remove 
it.

To modify an existing Digitizer EXjr 
installation
1 Close all programs but leave MS Windows® running.
2 Insert the Digitizer EXjr Installation CD-ROM.

If Digitizer EXjr is already installed on the computer, the 
following Welcome screen will appear.

3 Choose the option you require – Modify, Repair, 
Remove – and click Next.
If you choose to modify or repair your current 
installation, the Select Features screen will appear.

4 Select the components to install or remove:

Note  Total available space is automatically detected 
and displayed. This updates automatically depending 
on items selected.

5 Click Next.
The Ready to Install screen appears.

6 Click Install.
Upon successful installation of the software and any 
additional MS Windows® files that need updating, the 
Installation Complete screen appears.

Connecting to your machine

Once you have successfully installed and tested 
your Digitizer EXjr, you can attach your machine to 
your computer. To connect supported machines to 
a PC, you need to use a USB cable connected to 
your PC USB port. See your machine manual for 
details on connecting to computer.

Supported machine models and memory 
cards
Digitizer EXjr gives you the option of sending 
designs directly to machine or to memory card. 
The option you choose depends, in part, on the 
machine you are using.

Note  Before design files are sent to machine, they 
are automatically converted to JEF or JPX stitch file 
format.

Component Description
Digitizer EXjr Main Digitizer EXjr product.
Online Help Context-sensitive help – to invoke, use 

the F1 function key or click Help in the 
dialog boxes.

Onscreen 
Manual

An electronic Onscreen Manual – 
accessible via the Help menu.

Samples Sample embroidery designs and 
images – installed to the Embroidery 
Album folder on your hard drive.

Release 
Notes

An electronic (onscreen) set of Release 
Notes – accessible via the Help menu.

Extra 
Languages

In the multilingual version, extra 
languages are available. If onscreen 
documents are available in the same 
language(s) you select here – e.g. 
French – these will be installed 
automatically. If documents are not 
available in your selected languages, 
English documents will be installed. 
After installation, you can switch 
between languages using the Switch 
Language utility in the Program folder.

Component Description
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Supported machine models
Digitizer EXjr is able to automatically detect which 
type of supported machine is currently connected 
to the PC USB port. Select one of the available 
machine model sets as desired. This becomes the 
default machine type until you change it. See also 
Sending & writing designs.

Supported memory cards
Besides USB connection, you can write to an 
external media drive in a similar way as you would 
save to floppy disk. The ATA PC card is a PCMCIA 
standard PC memory card that is used for storing 
designs in JEF format to be read/written from/to 
machine. The ATA PC card is designated as a drive 
in your computer. The drive designation may 
become E: or F: or some other letter. After writing 
your design, you simply insert the card into the 
ATA PC card slot of your machine (if supported), 
and read the design.

Note  If your computer is a laptop, there may be a 
slot where you can insert the ATA PC card and its 
adapter directly. If you have desktop computer, 
you may need an ATA PC card reader/writer 
connected to a USB port.

USB memory sticks
The latest machine models can read from and write 
to USB memory sticks. These are very convenient 
portable memory devices which can hold large 
amounts of data in a small ‘stick’.

Linking your PC by USB cable
All the supported MS Windows® operating 
systems support the use of a USB cable to connect 
a supported machine directly to your PC, provided 
your PC has a USB port installed.

To link your PC by USB cable
1 Turn on your PC and sewing machine.
2 Connect the Type A connector to the PC and the 

Type B connector to the sewing machine.

Note  Do not turn the PC or sewing machine off before 
setup is complete.

3 Install the USB driver for the sewing machine.

Note  This setup procedure is only necessary on first 
usage. The cable can be disconnected with the power 
on or off.

Installing USB drivers for direct 
machine connection

USB drivers for direct machine connection are 
included on your Digitizer EXjr Installation CD. You 
need to install them when connecting your 
machine to PC. The Hardware Wizard automatically 
searches for the correct drivers and guides you 
through the process.

Note  Acutools for eXpressive920 and 
EmbroideryEditor for eXpressive830 are not 
supported under Windows XP.

Installing drivers for Windows XP
If you are running Windows XP, use the following 
procedure to install the required USB drivers.

USB cable
(12 Mb/s)

Type B 
connector

Type A 
connector
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To install a USB driver for Windows XP
1 Connect your machine to the computer with the USB 

cable and turn on both.
The computer will search for new hardware and prompt 
you to install a device driver.

2 Select No to the MS Windows® Update and click 
Next.

3 Select the automatic installation options, insert your 
installation CD into the CD ROM drive, and click Next.
The installation will search for a suitable device driver 
and prompt you to choose if it finds more than one copy 
on your system.

Note  The Jsmc860 device drivers are copied to the 
hard drive when the software is installed and don’t 
actually require the installation CD. The multi-needle 
machine requires the installation CD while the wizard is 
running in order for the Jsmc860 device drivers to be 
installed.

4 Choose an option and click Next to start installing.

The following dialog appears when installation is 
complete.

5 Click Finish to close and restart your computer.

Installing drivers for MS Windows® 
Vista/7
If you are running MS Windows® Vista or 7, use 
the following procedure to install the USB drivers. 
The machine USB drivers for 64 bit operating 
systems are included on your Digitizer EXjr 
Installation CD. You need to install them when 
connecting your machine to PC.

Note  There are two drivers: 770 or JsmcMul Device 
(for multi-needle embroidery machine), and 860 or 
Jsmc860 Device. The dialogs below show the multi 
needle embroidery machine.

To install a USB driver for MS Windows® 
Vista/7
1 Connect your machine to the computer with the USB 

cable and turn on both.
The computer will detect the machine and Windows 
Update will search for a device driver. You will see the 
message below on the task bar.

Note  This may take up to 10 minutes to display.
2 Click the message to display the following dialog.
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Note  Do not be alarmed by this message – it is just 
part of the process. Just continue with the instructions 
below.

3 Click Close.
4 Click Start, right-click Computer, and select Manage.

5 Select Device Manager in the left hand pane. 

6 Under Other Devices, right click 770 and select 
Update Driver Software.

7 Click ‘Browse my computer for driver software’.

8 Click the Browse button.

9 Select the arrow beside Computer and select the 
DVD/CD drive and insert the software disc if not 
already inserted. 

Note  For 32 bit operating systems you will have to 
browse to the specific 32 bit driver folder for your 
machine.

10 Click OK and then Next.

The Windows Security dialog is displayed when 
MS Windows® Vista/7 finds the drivers on the CD.

11 Click Install.
When successfully installed, the following dialog 
appears.

12 Click Close.
The driver installation is now complete and the 
machine can be accessed from within Digitizer EXjr. 
The machine can now be seen in Device Manager as 
JsmcMul Device or Jsmc860 Device.

Select 
Manage

Select 
Device 
Manager

Select ‘Update 
Driver Software’

Click ‘Browse my 
computer ...’

Click Browse button

Click arrow
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Calibrating the monitor

You need to calibrate your monitor so that designs 
at 1:1 scale appear at real size. Do this when you 
first install Digitizer EXjr or whenever you change 
your monitor.

To calibrate the monitor
1 Select Setup > Screen Calibration.

The Screen Calibration dialog opens.

2 Measure the height and width of the dialog box.
3 Enter the measurement in the Width and Height 

fields.
4 Click OK to confirm.

Measure width

Measure 
height
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Part I
Basics

Designs created in Digitizer EXjr are composed of ‘embroidery objects’. They 
are called ‘objects’ because they are discrete entities which can be 
manipulated independently of each other. Each object has certain defining 
characteristics or ‘details’ such as color, size, position, and so on. The most 
important property of an embroidery object is its stitch type.

Basic procedures
This section describes how to start the software, how to open designs, start 
new ones and save designs. It covers the use of basic commands. It also 
explains how to turn on and off the grid and hoop and measure distances 
on-screen. See Basic Procedures for details.

Grids & hoops
This section describes how to display hoops and grids in Digitizer EXjr as well 
as how to change hoops. It also deals with hooping large designs. See Grids 
& Hoops for details.

Viewing designs
This section explains the design viewing modes available in Digitizer EXjr as 
well as the various design viewing settings. It describes how to view the 
stitching sequence in slow motion. It also deals with viewing and hiding 
images as well as accessing design information. See Viewing Designs for 
details.
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Chapter 2

Basic Procedures

To start using Digitizer EXjr, you need to know a 
few basic procedures such as starting up, opening 
and creating designs, and saving. Others include 
showing and hiding the grid, displaying and using 
toolbars.
This section describes how to start the software, 
how to open designs, start new ones and save 
designs. It covers the use of basic commands. It 
also explains how to turn on and off the grid and 
hoop and measure distances on-screen.

Getting started

Digitizer EXjr can be launched from your Windows 
desktop or program group under the Start menu. 
Once started, you can open existing JAN files or 
create new files from scratch.

Starting Digitizer EXjr

Digitizer EXjr is launched from your Windows 
desktop. Before you can start using the 
application, the security device or ‘dongle’ must be 
attached to your PC. See also System security.

Warning  If the security device is removed or loses 
connection while you are working in Digitizer EXjr, 
error messages will display. Cancel the messages, 
then exit Digitizer EXjr. You will lose any unsaved 

changes to your design. Re-attach the security 
device to your computer, making sure that it is 
firmly secured, then restart Digitizer EXjr.

To start Digitizer EXjr
1 Double-click the Digitizer EXjr shortcut icon on the 

Windows desktop.
Alternatively, select Programs > Digitizer EXjr > 
Digitizer EXjr from the Start menu.
Digitizer EXjr opens with a new, blank design.

Double-click to start Digitizer EXjr.
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2 Choose from a set of pre-defined fabrics as required. 
See Changing fabrics & backgrounds for details.
Digitizer EXjr provides a set of optimized fabric settings 
so that the software will take into account the type of 
fabric you are stitching on.

3 Customize the design window by showing or hiding the 
grid, changing the grid dimensions, and showing and 
hiding toolbars. See Displaying hoops & grids and 
Showing or hiding toolbars for details.

Opening designs

Digitizer EXjr opens JAN files. See Embroidery 
design formats for details.

Warning  You cannot open files created with a later 
version of the software to the one you are running. 

To open a design
1 Click the Open icon.

The Open dialog opens.

2 Select a folder from the Look In list.
3 If the design is not in JAN format, select a file type from 

the Files of Type list.
4 Select a design or designs.

To select a range of items, hold down Shift as you 
select.
To select multiple items, hold down Ctrl as you 
select.

5 Select the Preview checkbox to preview the design (for 
supported file formats) together with design data. This 
includes stitch and color numbers, design height and 
width.

Try this!  For more information about a selected file, 
right-click in Windows Explorer and select Properties 
from the popup menu.

6 Click Open.

Creating new designs

When you start Digitizer EXjr, a new file is 
automatically created. By default, the blank design 
is based on the NORMAL template. Templates 
contain preset styles, defaults or objects, to make 
digitizing quicker and easier.

Try this!  Whenever you create a new design, save 
it with a new name. See Saving designs for details.

To create new designs
Click the New icon.
A blank design opens in the design window. See also 
Digitizing with Artwork.

Use Standard > Open to open an existing design.

Click Standard > New to start a new design with 
the NORMAL template. 
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Using commands

Once you start Digitizer EXjr, you use commands 
or tools, and dialogs to complete your tasks. You 
select commands in the same way as other 
Windows applications – from menus, toolbars, or 
popup menus.

Try this!  Keyboard shortcuts are also available for 
the most frequently used commands. See Quick 
Reference for details. 

Selecting commands from toolbars
Toolbars provide quick and easy access to 
Digitizer EXjr commands. Some of these 
commands are also available from dropdown 
menus. Click a toolbar icon to activate a command. 
Digitizer EXjr provides ‘flyout toolbars’ from the 
Digitize toolbar in order to minimize crowding. 
Selecting a tool on the flyout toolbar causes it to 
become the active tool on the Digitize toolbar.

To select commands from toolbars
Rest the pointer over a tool icon to see its name in a 
‘tooltip’.

Click the icon to activate the command.

Showing or hiding toolbars
Toolbars provide quick and easy access to 
Digitizer EXjr commands. You can choose to show 
or hide them for convenience.

Try this!  To increase your working area, hide 
unwanted toolbars and use the menu and 
keyboard commands instead. See Quick Reference 
for details. 

To show or hide toolbars
Select View > Toolbars.
The following toolbars are available to you in 
Digitizer EXjr.

Select the toolbars you want to display.
Deselect the toolbars you want to hide.

Note  Digitizer EXjr toolbars are dockable. To move a 
toolbar to a more convenient location, click and drag it. 
To dock it in its normal position, double-click the toolbar 
title.

Using popup menus
Right-clicking a selected object opens a popup 
menu containing frequently used commands.

To use popup menus
1 Right-click a selected object.

The popup menu opens.

2 Select a command from the menu.

Undoing & redoing commands

Use Standard > Undo to undo a command.

Use Standard > Redo to reapply a command 
which has been ‘undone’.

Select toolbars
to display

Right-click to 
invoke popup 
menu
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You can undo the effects of most commands. If you 
change your mind, you can redo them again. 
Digitizer EXjr remembers the last few commands 
you used.

To undo & redo commands
To undo a command, click the Undo icon.
When Digitizer EXjr cannot remember more 
commands, Undo is dimmed.
Click Redo to re-apply an ‘undone’ command.

Selecting machine models

Digitizer EXjr supports various sets of machine 
model. Some Elna machines can be connected by 
cable directly to your PC via the USB port. 
Older-style machines do not support direct 
connection but they do read ATA PC cards and/or 
USB memory sticks. See also Sending & writing 
designs.

To select a machine model
Click the Machine Model dropdown list on Standard 
toolbar.

Select one of the available machine model sets.

Displaying hoops & grids

A representation of the selected hoop is displayed 
in the design window. This provides a guideline for 
sizing and positioning designs. Use grid lines to 
help accurately align or size embroidery objects.

Displaying the hoop

Hoops are required to hold the fabric tight while 
stitching on your machine. They are available in 
different sizes. A representation of the selected 
hoop providing a guideline for sizing and 

positioning your design is displayed in the design 
window.

Note  The boundary of the working area within the 
hoop is displayed as a thin red line. If any part of 
the design lies outside the stitching area for the 
selected hoop, a warning appears when saving. 
This prevents you from accidently stitching outside 
this area and damaging your machine by hitting 
the hoop with the needle. You can show or hide the 
hoop at any time.

To display the hoop
Click the Display Hoop icon to toggle hoop display on 
or off.

Alternatively select View > Display Hoop.
Alternatively, right-click a blank part of the design 
window. This brings up a popup menu:

Displaying the grid

You can show or hide the grid at any time. 

To display the grid
Click the Display Grid icon to toggle grid display on or 
off.

Click View > Display Hoop to hide or show the 
hoop.

Select machine
model set

Click View > Display Grid to hide or show the grid.

Toggle hoop display on/off
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Alternatively select View > Display Grid.
Alternatively, right-click a blank part of the design 
window. This brings up a popup menu:

Displaying rulers & guides

Rulers are located to the top and left side of the 
design window. The unit of measurement – mm or 
inches – depends on the regional settings in the 
Windows Control Panel. The ruler scale, illustrated 
with numbers and ticks, depends on the zoom 
setting. Guides are dotted vertical and horizontal 
lines placed across the design window to help you 
align objects. Each guide has a yellow guide handle 
on the ruler that can be used to move or delete it. 
Guides are displayed ‘on top’ of the grid, if present, 
but ‘beneath’ vector objects and embroidery 
objects. Rulers must be displayed before a guide 
can be created.

Note  By default, rulers and guides are switched on. 
When they are switched off, guides are hidden but 
are stored in the design and will reappear when 
switched back on.

To display rulers & guides
Toggle ruler display by any of the following means:

Click the Display Rulers and Guides icon.
Right-click a blank part of the design window. This 
brings up a popup menu:

Select Setup > Work Environment > Display tab 
and select the Display Rulers and Guides option.

Select View > Display Rulers and Guides option.

Reset the ruler zero point by clicking and dragging the 
box in the top left-hand corner of the design window to 
the required point in the design.
The point where you release the mouse becomes the 
new zero point – X,Y (0,0). The grid always aligns with 
the rulers. See also Adjusting grid and guide settings.
To create a guide, click on either ruler – horizontal or 
vertical – and click-and-drag it into position. Multiple 
guides can be created and just as easily removed.
For more accurate positioning of guides, double-click 
the yellow handle. In the Guide Position dialog, enter 
a precise distance from the zero point, and click OK.

Note  The ruler zero and the design zero are not the 
same and in general do not coincide. When the zero 
point of the rulers is changed, the guides maintain their 
current displacement from the zero point of the design, 
not the zero point of the rulers.
To remove a guide, drag the yellow guide handle off the 
design window.

Click View > Display Rulers and Guides to toggle 
on rulers and guides. 

Drag the Ruler Zero Point to reset a new ruler 
zero point.

Toggle grid display on/off

Toggle rulers and 
guides on/off

Show Rulers
and Guides

Click-and-drag to
reset ruler zero

point

Click-and-drag to
reposition guides

Click ruler to
create new guide

Drag guide off
ruler to remove

Enter precise 
position
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Try this!  You can turn Snap to Grid and Snap to 
Guide on or off in the Work Environment dialog. See 
also Adjusting grid and guide settings.

Measuring distances on screen

Measure the distance between two points on 
screen using the Measuring Tape command. 
Measurements are shown in millimeters or inches, 
depending on the option selected in the Windows 
Control Panel. See your Windows documentation 
for more information.

Try this!  For more accurate results, zoom in before 
you measure. The measurement is always the 
actual size, and is not affected by the zoom factor.

To measure a distance on-screen
1 Select View > Measuring Tape.
2 Click the start point.
3 Move the pointer to the end point and hold the mouse 

still.
The tooltip displays the length of the measured line 
together with the stitch angle.

4 Press Esc to finish.

Note  You can also check the width and height of your 
design in the status bar.

Setting measurement units

You can use different measurement units within 
Digitizer EXjr without having to exit and change 
system settings. This is useful, for example, if you 
receive orders from places that use a different 
measurement system. The most common scenario 
is where a US customer orders lettering in inches 

– say ¾" – and the digitizing is to be done in 
metric. The digitizer can then easily enter ‘3/4"’ 
without having to first do any mathematical 
conversion to mm.

Changing the measurement system
The measurement system may be changed via a 
dropdown list on the View toolbar:

The first time you run Digitizer EXjr, the 
measurement system will default to whatever the 
operating system is using. If you change it in the 
software, the selected measurement system will 
default the next time you run it.

Note  Technically, when you select ‘U.S.’, you will 
get the imperial measurement system – inches, 
feet, and yards.

Ripple-on effects
Changing the measurement system will change the 
units used by most (but not all) controls. Stitch 
length and density controls will change to reflect 
the measurement system. 

Note  Elna machines have a dual measurement 
system which allows them to show stitch lengths 
as fractions of inches.

Specifying measurement units on-the-fly
As an alternative to changing the overall 
measurement system used in Digitizer EXjr, you 
can specify units of measurement when typing 
values into a measurement control. When you 
include the unit of measurement, the software 
automatically converts the entered value into the 
units of the control. 

Use View > Measuring Tape to measure distances 
on-screen.

Use View > Design Measurement System to 
change the measurement system used by the 
software.

Select desired 
measurement unit

Stitch length and density 
controls change to inches
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Say, for example, you are using the metric 
measurement system so your lettering heights are 
in mm. And say you get an order for ¾" lettering. 
Simply enter ‘3/4in’ or ‘3/4 in’ into the Lettering 
Height field and it is automatically converted to 
19.1mm. See also Adding lettering to embroidery 
designs.

Note  Digitizer EXjr supports both proper and 
improper fractions – e.g. ‘1 1/3’ as well as ‘4/3’. It 
does not, however, support mixed units – e.g. 1'3". 
Nor does it display values as fractions after they 
are entered, only during.

Supported units
Supported units include:

millimeters, mm 
inches, in
feet, ft
yards, yd 
centimeters, cm 
meters, m 

Try this!  Digitizer EXjr also allows entering units in 
text form, both English and the language the 
software is currently running in.

Changing fabrics & backgrounds

Embroidery stitches pull fabric inward where the 
needle penetrates. This can cause fabric to pucker, 
and gaps to appear in the embroidery. 
Digitizer EXjr provides a set of optimized fabric 
settings so that the software will take into account 
the type of fabric you are stitching on. You can also 
set colors both inside and outside the hoop to 
match the fabric you intend to stitch on.

Changing fabric settings
You can change fabric settings of existing designs. 
Choose from a set of pre-defined fabrics aimed at 
minimizing stitching defects when designs are 
sewn out. These make the necessary changes to 
the system settings – e.g. ‘stretchiness’. The new 
settings can be applied to all applicable objects – 
all object types other than Motif Fill, Appliqué, or 
Run. Objects can subsequently be modified via 
Object Details. See Editing Objects for details.

To change fabric settings
1 Select individual objects in your design as required.
2 Select Setup > Choose Fabric.

The Choose Fabric dialog opens.

3 Select a fabric type from the list.
The Required Stabilizer field displays the name of one 
or more recommended stabilizers and any other 
relevant information.

4 Click OK.
Stitch settings will be automatically adjusted for all 
applicable objects – i.e. all object types other than Motif 
Fill, Appliqué, Photo Click and Single Run.

Select fabric

Recommended 
backing and/or 
topping
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Changing background colors

Set the color inside the hoop to match the fabric 
you intend to stitch out on. You can also set a 
background color outside the hoop. See also 
Changing fabric settings.

To change the background color
1 Select Setup > Work Environment or right-click the 

design window and select from the popup menu.

The Work Environment dialog opens.

2 If not already selected, select the Colors option.
3 Select the Inside Hoop or Outside Hoop option as 

required:

4 Select a color from the palette or mix your own. See 
Mixing your own background color for details.

5 Click OK.

Changing background fabrics
Set the color inside the hoop to match the color of 
the fabric you intend to stitch out on. See also 
Changing fabric settings.

To change the background fabric
1 Select Setup > Work Environment or right-click the 

design window and select from the popup menu.
The Work Environment dialog opens.

2 Select the Inside Hoop or Outside Hoop option as 
required.

3 Select the Fabrics option.
The dialog changes as shown.

4 Click the Browse Fabrics button. 
The Select Fabric dialog displays a selection of fabric 
samples to choose from.

Use Setup > Work Environment to change background 
colors.

Option Purpose
Outside 
Hoop

When selected, you choose a background 
color to apply to the area outside the hoop, 
or when the hoop is not displayed, to the 
whole design window.

Inside 
Hoop

When selected, a background color can be 
applied within the hoop.

Choose Work
Environment

Choose to change
background inside

or outside hoop

Outside hoop area recolored

Fabric preview

Click to choose
sample
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Try this!  You can add your own fabric samples to the 
Fabrics folder in any of the supported file formats. You 
can also browse to another folder on your PC and 
select a file in any of these formats. See also 
Supported embroidery file formats.

5 Select a fabric sample and click Open or simply 
double-click the file.
The selected fabric is displayed in the hoop preview in 
the Work Environment dialog.

6 Click OK.
The selected fabric is applied to the whole design 
window.

Mixing your own background color

You can create a new background color for use with 
the current design. Each new design uses the 
default colors.

To mix your own background color
1 Select Setup > Work Environment.

The Work Environment dialog opens.

2 Select a color slot in the palette.
3 Click Mix Color.

The Colors dialog opens.

4 In the Standard tab, select a color that most closely 
matches the color you want.

5 In the Custom tab, click and drag the crosshairs on the 
color spectrum to get the exact color you require. 

6 Drag the slider on the right of the color spectrum to 
adjust color brightness.
The Hue, Luminosity and Saturation (HLS) and Red, 
Green and Blue (RGB) values appear in the bottom 
right-hand corner of the dialog. Enter these values 
directly if you want to define an exact color.

7 When you have mixed your color, click OK.
The new color appears in the selected color slot. 

Note  The new color is only saved with this design. 
New designs use the default colors.

Setting up color palettes

Digitizer EXjr lets you manage thread colors for 
each design you create or modify. Select from a 
wide range of commercial thread charts. Add or 
remove colors – you can assign up to 128 color 
slots. Find and sort specific colors by Color Code. 
See also Changing colors of selected objects.

Use Setup > Work Environment to mix a new background 
color.

Fabric applied to hoop and background

Click to mix color

Select color to 
replace

Click Docker > Color Palette to open the Color 
Palette. Use this to change colors of selected 
objects or set default color for new objects.

New color
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To set up a color palette
1 Click the Color Palette icon or press Ctrl+R.

Try this!  Resize and click-and-drag the Color Palette 
anywhere within the design window.

2 Access the Thread Colors dialog by one of the 
following means:

Select Setup > Thread Colors, or
Right-click a color in the color palette.

The Thread Colors dialog opens. The left-hand 
column represents the colors in the actual color palette. 
The right-hand column represents the threads 
available for use in the selected thread chart.

Note  If a color is already being used by one or more 
objects in the current design, a tick will appear in the 
color field of the Color Palette list.

3 Set the exact number of colors required in the Number 
of Colors field.
If you are only using six colors, limit the number in the 
Color Palette to those six. Add extra slots as required.

4 In the left-hand column, select the color slot you want 
to assign a thread to.

5 In the left-hand column, select a thread chart from the 
Thread Chart dropdown list.

6 Locate the color you want to use by scrolling down the 
list.

Try this!  If you know the exact code of the color you 
are looking for, key it into the Find Code field.

7 Use one of the following buttons to transfer the 
selected color to the Color Palette:

8 Repeat for other color slots in the color palette.

Note  The color palette you define here is saved with 
the current design.

Saving designs

Digitizer EXjr lets you save designs in native JAN 
as well as other ‘outline’ and ‘stitch’ file formats. 
See Embroidery design formats for details.

Saving current design

Saving a design records its file name, location and 
format, and updates it with any changes you 
make. When you save an existing design under a 
new name, to a different location or format, you 
create a copy of the original design. See Saving 
designs for machine for details.

Try this!  Save your design early and often. Do not 
wait until you finish working. You can also set 
Digitizer EXjr to save automatically while you 
work. See Setting automatic save options for 
details.

Select thread 
chart

Replace or 
add threads 
to color 
palette

Button Purpose
Replace The color will replace the currently selected 

color in the Color Palette list. 
Double-clicking a thread in the Thread 
Chart list has the same effect.

Add The color will be appended to the Color 
Palette list. The Number of Colors field will 
increase by one.

Match & 
Replace 
All

All colors in the Color Palette list will be 
replaced by the nearest matching color 
from the selected Thread Chart. This 
provides a quick way to switch between 
thread brands.

Use Standard > Save to save the current design.
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To save a design
1 Click the Save icon.

If this is the first time you have saved the design, the 
Save As dialog opens.

Try this!  To save changes to an existing file but 
preserve the original, use Save As.

2 Select the folder where you want to save the design 
from the Save In list.

3 Enter a name for the design in the File name field.
4 Select a file format from the Save as type list. See 

Supported embroidery file formats for details.
5 Click Save.

Once you have saved a design, every time you click 
Save on the toolbar the file will be updated.

Note  Files saved in JAN format are automatically 
compressed when saved and decompressed when 
re-opened. This reduces the storage space required, 
and makes it possible to save large files for sending as 
email attachments.

Setting automatic save options

Save your work automatically at regular intervals 
using Auto Save to protect you from losing work 
in the event of hardware or software failure.

To set automatic save options
1 Select Setup > Work Environment.

The Work Environment > Display dialog opens.
2 Select the Autosave tab.

3 Select the Auto Save Design Every checkbox.
4 Enter the auto-save frequency in the Minutes field. 

The design will be saved in the BACKUP folder of your 
Digitizer EXjr installation. It will have the same name as 
the original file with the extension BAK.

Warning  Backup files remain in the Backup folder 
until you delete them. To prevent the folder from using 
too much hard disk space, delete unwanted files 
regularly.

5 Click OK.

Setting scrolling options

The Work Environment > Scrolling tab allows 
you to control the behavior of both mouse and 
mouse wheel within Digitizer EXjr. Use Auto 
Scroll to scroll automatically within the design 
window while digitizing. This can be more 
convenient than using panning or scroll bars, 
especially when working on large designs. The 
dialog also allows you to set four different mouse 
wheel behaviors based on your selection of default 
options. Whenever a setting is changed, the 
system will recommend the other mouse wheel 
behaviors, but you have complete control to 
change as desired.

To set scrolling options
1 Select Setup > Work Environment.

The Work Environment dialog opens.
2 Select the Scrolling tab.Select Setup > Work Environment to set automatic save 

options.

Format listDesign name

Folder containing design Select
Autosave
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3 Adjust Auto Scroll options as required:

The effect of the Auto Scroll setting only becomes 
apparent when you start to digitize. The design window 
automatically scrolls to follow the current cursor 
position. 

4 Select the pointer position after scrolling from the Move 
Pointer To list:

5 Set the precise behavior of your mouse wheel action as 
desired.

The same four options are available for use when 
deploying the mouse wheel on its own or in 
combination with Alt, Ctrl, and Shift keystrokes. That 
is, you can program the wheel to scroll horizontally, 
vertically, or zoom by preset factors.

6 Tick Center Pointer when Zooming to ensure that the 
pointer stays centered on screen at all times.

7 Click OK.

Try this!  Hold down the Shift key to temporarily 
deactivate Auto Scroll.

Option Purpose
Auto Scroll Tick checkbox to enable automatic 

scrolling while digitizing.
Move Pointer 
After Scroll

Tick checkbox to force pointer to 
move with the current cursor position 
after each scroll.

Response 
Time

Enter smaller values to increase 
scrolling speed.

Option Purpose
Center Center of the window. Use this 

setting for large movements.
Midway Halfway between the original pointer 

position and the center of the 
window. Use this setting for smaller 
movements – e.g. when zooming into 
a small area of the design.

Corner The edge of the screen. Use this 
setting for slow scrolling.

Adjust auto-scroll 
speed and pointer 
position

Select Auto Scroll 
and Move Pointer 
After Scroll

Select desired 
action for your 
mouse wheel
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Chapter 3

Grids & Hoops

Hoops are required to hold the fabric tight while stitching on your machine. 
They are available in different sizes. Digitizer EXjr allows you to select from a 
wide range of standard factory-supplied hoops. A representation of the selected 
hoop providing a guideline for sizing and positioning your design is displayed in 
the design window.

This section describes how to display hoops and grids in Digitizer EXjr as well 
as how to change hoops. It also deals with hooping large designs.

Adjusting grid and guide settings Use grid and guide lines to help accurately align or 
size embroidery objects. Turn on or off the grid, or 
change grid spacing as required.

To adjust grid and guide settings
Select Setup > Work Environment.
The Work Environment > Display tab opens.

Click View > Display Grid to hide or show the 
background grid.

Click View > Display Rulers and Guides to show 
or hide rulers and guides. Right-click to change 
the Guides settings.
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Select the Display Grid checkbox to display the grid.

Adjust Grid Spacing by moving the slider.
The spacing value is displayed above the slider.
Select the Snap to Grid checkbox as required.
Reference points, control points or leading edges of 
objects snap to the grid during digitizing, sizing, 
reshaping, or positioning operations.
Select the Display Rulers and Guides checkbox as 
required. The Snap to Guides control can be set 
indepently of Snap to Grid.

Try this!  To use these settings as defaults for the 
current template, click Save. See also Creating new 
designs.
Click OK.

.Selecting hoops

Whenever you create a new design, a single hoop 
representing the embroidery hoop you connect to 
your embroidery machine appears by default in the 
middle of the design window. The selected hoop is 
saved with the design in the native JAN file format. 
It is also saved to the JEF file which the machine 
reads. A range of hoop sizes is available for a wide 
variety of design types. You can also change hoop 
orientation on screen for ease of digitizing. See 
also Rotating hoops.

Make sure you have the correct hoop selected and 
that your design fits within the design area on your 
embroidery machine. When the machine reads the 
JEF file, the stitching area is limited by the selected 
hoop type. See also Hooping large designs.

Changing hoops

It is a good idea to have the correct hoop selected 
before you stitch out a design. But sometimes you 
may wish to change hoops before stitching out. 
The Hoop Type dropdown list control lets you 
quickly confirm what hoop is currently being used 
and change it at any time. Select the smallest hoop 
which fits the design from the available range. See 
Supported hoop types for details.

To change hoops
Select a hoop type by either of the following means:

Select from the Hoop Type dropdown menu on the 
View toolbar.

Select Setup > Work Environment and select a 
hoop from the Hoop list.

Select
Display Grid

Select Display
Rulers and Guides

Grid spacing: 10 mm Grid spacing: 4 mm

Use Hoop Type dropdown list 
to change hoops.

Select available
hoop type
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Try this!  The hoop background color can be changed. 
See Changing fabrics & backgrounds for details.

Centering hoops
The Automatic Centering function ensures that 
the center of the hoop (or offset center for older 
style hoops – i.e. Hoop No.1&3), is automatically 
positioned at the center of the current design, or at 
the (0, 0) point of the current design window while 
the design contains no stitches. Otherwise the 
hoop center – or offset center for old hoops – is 
fixed at the (0, 0) point of the current design 
window.

To center the hoop
1 Open the Work Environment dialog:

Select Setup > Work Environment.
Right-click on the design window with nothing 
selected and select Work Environment. 

2 Click the Automatic Centering checkbox in the 
Hoops tab.

Rotating hoops

The Rotate Hoop tool allows you to rotate the 
hoop for ease of digitizing. The attachment 
mechanism is indicated, both on screen and 
printed worksheets. You can thereby tell the 
orientation of the design with respect to the hoop 
and decide how to position it. Rotate the current 
hoop by any one of the means described below.

To rotate the hoop
Click the Rotate Hoop 90° CCW / CW icon.

Right-click anywhere in the design window with nothing 
selected and select Rotate Hoop > 90° 
Counterclockwise or 90° Clockwise.

Hooping large designs

A problem arises when you create a large design 
which has multiple design elements spread over a 
large area which cannot fit in a single hoop. Using 
the Combine toolbar functions, you can combine 
one or more designs in a single hoop or place 
multiple hoops over a large design layout. These 
can then be sent to the embroidery machine as a 
single JEF file per hooping. You can also print a 
template which can be used to position each of the 
hooped portions of a design. See also Printing 
design layouts.

Note  Digitizer EXjr supports the Giga hoop. This is 
a two-position hoop which expands the available 
sewing area. When sending to machine, in most 

Use Combine > Rotate Hoop 90° CCW / CW to 
rotate the hoop 90° in either direction.

Select automatic 
centering

Choose rotation
option
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cases Digitizer EXjr will only create one file as the 
two hoop positions are saved in a single JEF file. 
See Sending designs with a Giga Hoop for details.

Try this!  Digitizer EXjr allows you to define a work 
area of up to 3m x 3m. See Creating ornamental 
layouts for details.

Creating a multi-hooping sequence

When a large design or design layout requires 
multiple hoopings, it is important to establish the 
stitching order so that objects in the foreground 
are sewn after those in the background. 
Digitizer EXjr allows you to set up the position and 
sequence of each hoop. Multiple hoops are 
color-coded as follows, according to their position 
in the sequence:

Note  In the unlikely event that you use more than 
eight hoopings, the color sequence is repeated, as 
long as none of the previously created hoop 
positions is deleted.

To create a multi-hooping sequence
1 Open or create the large design or design layout you 

want to sew out. See also Creating ornamental layouts.

2 Choose the hoop you want to work with from the 
dropdown list. See .Selecting hoops for details.

3 Click the Combine Mode icon.
This places the design in Combine Mode view and 
enables the Add Hoop and Calculate Hoopings tools.

4 Click the Add Hoop button to add another hooping.
5 Position this over the design elements you want to 

stitch first.

Use Combine > Combine Mode to activate the 
Combine functions.

Use Combine > Add Hoop to center a new hoop 
in the design window in an upright orientation.

Use Combine > Delete Hoop to remove selected 
hoops from the design window.

Use Combine > Calculate Hoopings to evaluate 
the hoopings that will result from the current hoop 
layout.
Click Combine > Rotate Hoop with left or right 
mouse buttons to rotate a selected hoop 90° in 
either direction.

Hoop Color
1 Dark Green
2 Blue
3 Red
4 Brown
5 Orange
6 Purple
7 Teal
8 Aqua
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6 Repeat these steps as required.

Try this!  You can select a different hoop at any time. 
This will change all hoopings in the design.

7 Re-position additional hoops and, if necessary, rotate 
them so that they completely cover all objects in the 
design.

Click the Rotate Hoop icon with left or right mouse 
buttons to rotate a selected hoop 45° in either 
direction.
Alternatively, click the hoop again and rotate hoops 
by means of rotation handles and rotation 
center-point.

Try this!  Nudge selected hoops into position using the 
Arrow keys.

8 Delete hoops as required with the Delete Hoop icon or 
Delete key on your keyboard.

9 Repeat these steps until all design elements are 
covered.
All covered design elements are displayed in green.

10 Finally, click the Calculate Hoopings icon to evaluate 
the hoopings that will result from the current hoop 
layout.

You are now ready to save the design to one or more 
files or send it to machine. See Reading & Writing 
Design Files for details. 

Try this!  Print a copy of the design showing the hoop 
positions to help you stitch it in the correct hooping 
order. See Printing design layouts for details.

Outputting alignment marks
In order to help you correctly align multiple 
hoopings during stitchout, Digitizer EXjr can stitch 
out alignment marks for each hooping. These do 
not form part of the design and are not saved with 
the design file. However, they are added during 
output and are viewable in the production 
worksheet hooping list.

Try this!  Correct alignment of multi-hooped 
designs requires some practice. Third-party 
training progams are available on the internet 
which demostrate correct technique. Most 
recommend using a sticky-back tear-away 
stabilizer, heavy enough so that the alignment 
marks do not tear the stabilizer. Use pins through 
the alignment marks of one hooping to align the 
corresponding marks of the next hooping.
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To output alignment marks
1 Open or create the large design or design layout you 

want to sew out. See also Creating ornamental layouts.

2 Right-click the design window and select Work 
Environment from the popup menu.

3 Select the Combine tab and choose the Add 
Alignment Marks on Output option.

4 Adjust the margin settings as required.
The larger the margin, the greater the distance 
between the alignment mark and the maximum 
embroidery area of the hoop. This makes it easier to 
align but there may be some tradeoff in precision.

Try this!  To check that alignment marks have been 
added, activate the hooping list in Print Preview. See 
Printing multi-hooped designs for details.

Choose to add 
alignment marks

Alignment marks included
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Chapter 4

Viewing Designs

Digitizer EXjr provides many viewing features to 
make it easier to work with your design. Zoom in 
on an area to see more detail or view the design at 
actual size. Show or hide various design elements 
with the available display settings.
Digitizer EXjr also provides information about 
designs in a variety of ways and formats. Before 
even opening Digitizer EXjr or your design, you can 
check the design information for JAN or JEF files 
directly from Windows Explorer. The design 
printout too provides essential production 
information, including a design preview, the size of 
the design, color sequence and any special 
instructions.
This section explains the design viewing modes 
available in Digitizer EXjr as well as the various 
design viewing settings. It describes how to view the stitching sequence in slow 
motion. It also deals with viewing and hiding images as well as accessing 
design information.

Viewing design elements

Digitizer EXjr provides many viewing modes to 
make it easier to work with your design. Zoom in 
on an area to see more detail or view the design at 
actual size. You can show or hide design elements 
with a variety of display settings.

Viewing parts of a design
Digitizer EXjr provides a number of techniques for 
quickly displaying the whole design in the design 
window. You can set your system to display all 
embroidery objects in a design, or hide all but the 
selected objects.

To view parts of a design
To view the whole design, select View > Zoom > 
Whole Design or press 0.
To view the whole hoop, select View > Zoom > Whole 
Hoop or press /.
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Select object/s to show.

Select View > Show > Selected Objects Only.
Only objects that are currently selected are visible. This 
option is only available when objects are selected.
To display selected colors in the window, select View > 
Show > Selected Colors Only.

Select the colors to display and click OK. See also 
Viewing and selecting colors.

To fit the objects in the design window, press 0.
To view the whole design again, select View > Show > 
All Objects.

Note  This option is only available when one or more 
objects are already hidden.

Zooming & panning designs

Magnify your view of the design by zooming in on 
individual stitches or details, or zoom out to display 
more of the design in the window. In addition to 
the scroll bars, panning provides a quick way to 
view parts of a design which are not currently 
visible in the design window. Panning is typically 
used after zooming in on an area.

To zoom & pan a design
To display a design at twice its current size, select View 
> Zoom In.
To display a design at half its current size, select View 
> Zoom Out.
To zoom in on a section of the design, select a zoom 
percentage from the Zoom Box.
To zoom in on a section of the design, press the B key 
on your keyboard, then drag a bounding box around 
the zoom area.

Click View > Zoom In to display a design at twice 
its current size.

Click View > Zoom Out to display a design at half 
its current size.

Click View > Zoom Box and enter a percentage 
value to zoom in on a section of a design.

Select View > Zoom > Whole Hoop to view the 
whole hooped area.
Select View > Zoom > Whole Design to view the 
whole design.
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To pan across a design in the design window, select 
View > Pan or press P. 
The cursor changes to a grabbing hand symbol. When 
you click and hold, you can drag the image around to 
reveal different parts of the design.

Click and hold again to pan to a different location. To 
release the command, click Pan or press the ‘P’ key 
again, or select another tool.
Press Esc to cancel tool selection.

Design viewing modes

Digitizer EXjr provides a number of viewing modes 
to selectively display design details.

Viewing designs with Visualizer

Visualizer offers a graphical representation of what 
the final embroidery will look like.

To view designs with Visualizer
Click the Visualizer icon to switch between Visualizer 
and normal view.

Try this!  Use Visualizer together with a background 
fabric to see how your design will look when stitched 
out. See Changing fabrics & backgrounds for details.

Viewing connectors
The software automatically adds connectors 
between objects in a design. When connectors 
become long enough to trim, the software 
automatically adds tie-in and trim commands 
indicated by the symbols shown below.

Your machine has a mechanism to trim by distance 
internally according to the stitch data it receives. 
Sometimes, however, it does not actually trim even 
though there is a trim symbol in the design. But it 
will always create a tie-off.

Note  Old designs which have different connector 
settings do not display trim symbols at all in some 
cases where the machine actually trims. You can 
overcome this by inserting the old design into a 
new blank design. The old design will inherit the 
new connector settings.

Click View > Visualizer to change between normal 
view and Visualizer view.

Click & drag
bounding box

around area to
zoom

Click & drag to part of 
design you want to view

Normal view Visualizer on

Trim symbol

Tie in symbol
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The symbols shown below may also appear and are 
helpful in understanding what appears on-screen.

Traveling through designs

When working with embroidery designs, you need 
to understand the stitching sequence. You can view 
a design’s stitching sequence in Digitizer EXjr by 
‘traveling’ through it by colors. Digitizer EXjr 
simulates stitching out by changing stitches from 
black to their allocated thread color as they are 
‘stitched’.

Traveling by color
Use the Jump by Color function to travel through 
the design by color. This is useful if you need to 
locate a specific color change in order to insert an 
object or delete it from the stitching sequence.

To travel by color
To travel to the start of the design, press the Home 
button on your keyboard.
To travel to the next color, press the PageDown button 
on your keyboard.
To travel to the previous color, press the PageUp 
button on your keyboard.
To travel to the end of the design, press the End button 
on your keyboard.

Simulating design stitchout

The Slow Redraw tool lets you simulate the actual 
embroidery design stitchout on screen. Use it to 
view design stitching and color sequence in slow 
motion. Simulation can be started from any stitch 
in the design. Hide previously stitched areas as 
required. With larger designs, scroll automatically 
so that the area being stitched remains on screen.

Because Slow Redraw emulates the movements 
of the embroidery machine, you are able to make 
decisions about how to optimize your design in 
order to lessen the load on the machine. This is 
particularly important if you intend to make 
multiple stitchouts of the same design. It is good 
practice to perform Slow Redraw on completed 
designs for this reason.

Note  Slow Redraw cannot be used with 
Visualizer.

To simulate design stitchout
Click the Slow Redraw icon or press Shift+R.
The Slow Redraw dialog opens.

End of design

Current stitch 
cursor

Start of design

Use View > Slow Redraw to view the stitching and 
color sequence of a design in slow motion.

Only bowling balls 
redrawn – prior 
stitching hidden
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Click the Play button.
The design is redrawn on screen according to stitching 
sequence.
Use the slider bar to adjust the simulation speed.
Adjust control buttons as required:

To redraw only a section of the design, specify a start 
point for either forward or backward stitching in the 
Stitch Range field or via the slider control.

Select simulation options as required:

Viewing & hiding images

You can show or hide a bitmap backdrop 
temporarily while you work. Hiding backdrops does 
not delete them from the design. See also 
Inserting images.

To view or hide images
Click the Display Images icon or press D.
When selected, backdrop images are visible. See also 
Viewing parts of a design.

To hide the image, click Display Images or press D 
again.
Click the Display Vectors icon or press Shift + D to 
display or hide vector graphics.

Viewing design information

Digitizer EXjr provides information about designs 
in a variety of ways. Before even opening 
Digitizer EXjr, you can check design information 

Control Function
Reverse Play backwards from current stitch.
Play Play forwards from current stitch.
Pause Pause simulation at current stitch.
Stop Stop simulation and return to beginning of 

design.
Back to 
Start

Redraw from start of design.

Adjust stitch range

Run simulation with 
‘video’ controls

Control stitchout
speed

Simulation options

Stitch range set to 
redraw from this 
point

Control Function
Hide 
Before

Hide all stitching prior to the current cursor 
position. Only design outlines are shown.

Auto 
Scroll

With larger designs, scroll automatically so 
that the area being stitched remains 
on-screen.

Use View > Display Images to show and hide 
backdrops.

Click View > Display Vectors to toggle on/off 
display of vector graphics.

Image displayed Image with 
selected objects

Image display 
deactivated



Digitizer EXjr Instruction Book
Chapter 4 Viewing Designs

32

directly from Windows Explorer. The Open dialog 
also gives you important file information. The 
status bar in the design window is another source 
of information about designs. The print preview 
provides complete design information.

Viewing design details
Within Digitizer EXjr, the Open dialog gives you 
important file information as well as the status bar 
in the design window.

To view design details
Click the Open icon.
The Open dialog shows limited information about 
selected designs in the preview panel.

When you open a design, the status bar shows design 
information such as total stitch count.

Previewing design printouts

The print preview contains a design preview and 
essential information, including the size of the 
design, color sequence and any special stitching 
instructions. See also Printing Designs.

To preview a design printout
1 Click the Print Preview icon.

The design printout displays in a preview window.

2 Adjust the view as required:
To change the orientation of the paper, click 
Landscape or Portrait.
To change the information that displays, click 
Options. See also Setting print options.
To print the design, click Print.
To close the print preview, click Close.

Try this!  Zoom in to view the design preview more 
closely. Large designs may be displayed over a 
number of pages.

Click Standard > Print Preview to preview the 
design printout on screen.

Total stitch 
count

Design 
dimensions

Thread color of 
selected object
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Part II
Digitizing
Essentials

In Digitizer EXjr, designs are composed of basic shapes or ‘embroidery 
objects’. These are like ordinary drawing objects in that they have certain 
defining characteristics or ‘details’ such as color, size, position, and so on. 
They also have settings unique to embroidery such as stitch type and 
density.

Digitizing with artwork
This section describes how to import suitable artwork into Digitizer EXjr and 
convert it automatically to embroidery. It also explains how to automatically 
generate outlines and borders. See Digitizing with Artwork for details.

Editing objects
This section describes how to select objects using the selection tools. It also 
covers modifying object details, including line stitch and fill stitch details. 
See Editing Objects for details.
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Chapter 5

Digitizing with Artwork

Artwork can be inserted or pasted into 
Digitizer EXjr for use as digitizing templates or 
‘backdrops’. Digitize complete images 
automatically with the Click-to-Design tool. 
You select the image and the tool automatically 
determines the shapes and stitches needed to 
digitize the design.
This section describes how to import suitable 
artwork into Digitizer EXjr and convert it 
automatically to embroidery. It also explains 
how to automatically generate outlines and 
borders.

Choosing suitable artwork

For both manual and automatic digitizing 
purposes, ‘clean’ images, sometimes referred to as 
‘cartoons’, work best. Such images have a limited 
number of solid colors which in turn have 
well-defined outlines. Ideally, they are:

Well defined, where each shape is made up of 
pixels of the same color
Clearly ‘blocked’, where each shape is a 
stitchable size, at least 1 sq mm
Saved at a color depth of at least 256 colors (8 
bit), or preferably millions of colors (16 bit). 
(Images are automatically reduced to 256 
colors or less when loaded into Digitizer EXjr.)

Automatic digitizing techniques produce best 
results with images of the type found in clipart 

Clean picture with 
well-defined outlines

Clean picture with 
well-defined color blocks

Complex picture, needs 
editing to remove 
background and clean color 
blocks
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libraries or created from scratch in a graphics 
package. Automatic digitizing can work with 
images from other sources but they require some 
preparation. This is because most commonly 
available images are not made up of solid colors. 
Scanners introduce noise, while graphics packages 
perform ‘dithering’ and ‘anti-aliasing’ to improve 
image print quality.
Automatic digitizing works least effectively with 
photographic images which may contain many 
dithered colors and complex forms. With 
photographs, however, you can pick out shapes 
that you want to embroider, leaving out 
unnecessary detail.

Scanned images
Images scanned from 
hardcopy drawings or 
existing embroidery typically 
contain a lot of introduced 
‘noise’. While they can be 
used as input to automatic 
digitizing, once again, best 
results are achieved with 
relatively clean images 
consisting of solid color 
blocks. Typically, logos and 
simple drawings scanned 
from business cards, 
letterheads, books, 
magazines, cards fall into 
this category.
Noisy images typically need to be prepared by 
reducing the color count and sharpening the 
outlines.

Dithered images
Dithering is a software technique which combines 
existing colors in a checkerboard arrangement of 
pixels. It is typically used to simulate colors that 
are missing from an image palette.

Like noisy images, dithered images need to be 
color-reduced before use. Be aware, however, that 
while the software is excellent at processing 
dithered colors within a defined outline, it does not 
work so well with non-outlined images.

Anti-aliased images
Anti-aliasing is a software technique similar to 
dithering which is used to soften hard outlines 
where color blocks intersect. It produces smoother 
outlines by ‘blurring’ the pixels where colors join.

Where anti-aliasing is deliberately used to blur 
outlines, these need to be ‘sharpened’ before use 
with automatic digitizing.

Importing images into 
Digitizer EXjr

Bitmap images can be inserted or pasted into 
Digitizer EXjr for use as digitizing backdrops. For 
digitizing purposes, ‘clean’ images, sometimes 
referred to as ‘cartoons’, work best.

Image containing a lot of 
scanner ‘noise’

Dithered color 
blocks

Anti-aliased outlines
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Try this!  You can scale and transform images after 
importing, but it is generally better to do so during 
scanning. Scaling afterwards may distort the 
image.

Inserting images

You can load bitmap images of various formats for 
use as digitizing backdrops. See also Choosing 
suitable artwork.

Note  Vector drawings are converted to bitmap 
images when loaded into Digitizer EXjr.

To insert an image
1 Select Image > Insert Image.

The Open dialog opens.

2 Select a folder from the Look In list.

3 Select a file type from the Files of Type list – e.g. BMP.
4 Select the file you want to insert.
5 Click Open.

Try this!  Select the Preview checkbox to preview the 
selected file.

Copying & pasting images

You can copy and paste an image into 
Digitizer EXjr by copying it from another 
embroidery design or graphics application, and 
pasting it into your design.

To copy and paste an image
1 Select the image you want to copy and paste.
2 Copy it to the Windows clipboard by pressing Ctrl+C.
3 Create a new file in Digitizer EXjr or open the design 

file into which you want to insert the image.
4 Click the Paste icon or press Ctrl+V.

The image is pasted into the design.

Note  You may need to resize the image to fit within the 
dimensions of the selected hoop. See Scaling objects 
via settings for details.

Preparing images for digitizing

Use the Image Preparation tool to prepare 
images for automatic digitizing. The tool 

Use Image > Insert Image to insert an image for use as a 
backdrop. 

Traced image Auto-digitized

Select folder

Select required format

Click Standard > Paste to paste copied images in 
the design.

Use Digitize > Image Preparation to reduce the 
number of colors and remove image ‘noise’ in 
non-outlined images.



Digitizer EXjr Instruction Book
Chapter 5 Digitizing with Artwork

37

automatically reduces color blocks in bitmap 
images to a single color, removing anti-aliasing and 
noise. You can let the software reduce the color 
count automatically or specify a precise number. 
The latter is useful if you want to match design 
colors to an exact number of thread colors.

Try this!  Depending on the quality of the scanned 
image, you may need to touch it up manually 
before processing in Digitizer EXjr. You would 
normally do this in order to eliminate backgrounds, 
flood-fill solid areas with color, or add outlines, 
close gaps, crop areas or reinforce outlines.

To prepare images for digitizing
1 Scan or load an image.

2 Click the Image Preparation icon.
The Auto Color Reduction dialog opens.

The image appears in the preview panel. The 
Available field shows the number of image colors.

3 Check how many colors are in the image.
This is indicated by Available. If there appear to be too 
many, the image probably contains noise.

4 Enter the number of colors you require.
The preview shows you how the design will look.

5 Click OK to apply the changes.

Digitizing images with 
Click-to-Stitch

The Click-to-Stitch tools provide everything 
necessary to digitize shapes in bitmap images 
automatically without using manual input 
methods. These tools are useful for quickly 
creating embroidery objects from scanned images 
that do not require particular artistic effects or 
embroidery-specific knowledge.

Note  Even if your artwork looks ready to stitch, it 
needs to be image-processed first. See Preparing 
images for digitizing for details.

Matching palette colors to an image

Image scanned in 
RGB color mode – 
converted to 256 
colors upon loading

Enter number
of colors

Use Digitize > Click-to-Parallel Weave Fill to 
digitize large artwork shapes with Parallel Weave 
Fill, preserving any holes within.
Use Digitize > Click-to-Parallel Weave Fill without 
Holes to digitize large artwork shapes with 
Parallel Weave Fill, ignoring any holes within.

Use Digitize > Click-to-Centerline to digitize 
centerlines in artwork with run line stitches.

Use Digitize > Match to Palette to find the nearest 
match between a selected image color and thread 
color.

Use Digitize > Match to Palette to find the nearest 
match between a selected image color and thread 
color. If not selected, the color is digitized in the 
current palette color.

Reduced to 5 colorsReduced to 3 colors
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Use the Match to Palette tool to find the nearest 
match between a selected image color block and a 
palette color. If Match to Palette is not selected, 
the color block is digitized in the current palette 
color.

To match palette colors to an image
1 Scan or load an image.

2 Select the image and process it. See Preparing images 
for digitizing for details.

3 Click the Match to Palette icon.
4 Select a Click-to-Stitch digitizing method.
5 Click the shape you want to digitize.

The object is digitized in the nearest palette color.

Note  If Match to Palette is not selected, the object is 
digitized in the current palette color.

Digitizing fills with Click-to-Stitch

Click-to-Stitch can be used to create ‘closed’ 
Weave Fill objects. Use Click-to-Parallel Weave 

Fill to digitize large areas in your artwork with 
Weave Fill stitching, preserving any holes within 
them. If you want holes ignored, use the 
Click-to-Parallel Weave Fill without Holes 
tool. Current properties are applied. You can 
modify these as required before or after using the 
tools.

To digitize fills with Click-to-Stitch
1 Scan or load an image. 
2 Select the image and process it. See Preparing images 

for digitizing for details.
3 Select a thread color from the color palette.

Alternatively, use the Match to Palette tool to find the 
nearest matching thread color. See Matching palette 
colors to an image for details.

4 Select the required Click-to-Stitch fill input method.
5 Click the shape you want to digitize.
6 Press Enter. 

The shape is immediately filled with stitches. 

7 Digitize other filled shapes in the artwork in the same 
way changing thread color and input method as 
required.

8 Click Visualizer to check the result.

Note  Stitches are generated according to current stitch 
settings. These can be modified.

Use Digitize > Click-to-Parallel Weave Fill to 
digitize large artwork shapes with Parallel Weave 
Fill, preserving any holes within.
Use Digitize > Click-to-Parallel Weave Fill without 
Holes to digitize large artwork shapes with 
Parallel Weave Fill, ignoring any holes within.

Matched to palette Digitized in current color

Click the object

Object filled 
with stitches 

All filled areas
digitized and shown

in Visualizer
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Digitizing outlines with Click-to-Stitch

Use Click-to-Stitch to digitize boundaries and 
details with run stitching. Current properties are 
applied. You can modify these as required before 
or after using the tools.

To digitize outlines with Click-to-Stitch
1 Scan or load an image. 
2 Select the image and process it. See Preparing images 

for digitizing for details.
3 Select a thread color from the color palette.

Alternatively, use the Match to Palette tool to find the 
nearest matching thread color. See Matching palette 
colors to an image for details.

4 Select Click-to-Centerline to digitize centerlines in 
your artwork with run stitching.
Stitches are generated according to current stitch 
settings.

Digitizing images with 
Click-to-Design

In essence, creating an embroidery design with the 
Click-to-Design tool is simply a matter of 
selecting the image you want to convert, and 
clicking the tool. The system automatically 
determines the color to omit, fill colors, detail color 
and most suitable stitch types to apply to an image 
using the default settings. Click-to-Design also 
determines the stitching sequence based on 
closest join.

To create a whole design with Click-to-Design
1 Insert an image into Digitizer EXjr and select it. See 

Importing images into Digitizer EXjr for details.
The Click-to-Design tool becomes available for use.

Note  Only one image may be selected at a time. The 
tool is disabled if the selection contains anything other 
than an image. 

2 Click the Click-to-Design icon.
The Click-to-Design dialog opens. The dialog 
combines two primary functions – color reduction and 
stitching options.

The Color Reduction panel provides two views of the 
selected image:

Left panel: displays the original image color count.
Right panel: displays the processed image color 
count. This automatically updates as settings are 
adjusted.

The Color Reduction panel also includes these 
buttons:

Use Digitize > Click-to-Centerline to digitize 
centerlines in artwork with run line stitches.

Use Click-to-Design (Digitize toolbar) to create 
embroidery designs directly from imported 
images using default settings.

Click to digitize centerline
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3 Check how many colors are in the image.
This is indicated in the Available field. If there appear 
to be too many, the image probably contains unwanted 
noise.

4 Use the Auto Color Reduction control to reduce the 
color count to a precise number.
This is useful if you want to match design colors to an 
exact number of thread colors.

5 Enter the exact number of colors you require.
The preview panel updates immediately.

6 Click OK to apply the changes.
You are returned to the Click-to-Design dialog. The 
Stitching Options options are now available.

By default, outlines and borders are set to ‘none’. If 
your artwork is suitable, enable outlines and/or borders 
as desired:

Generated outline stitching uses Run Line stitching 
to surround separate color blocks in the source 
image. The Run Line stitching has the same stitch 
settings as any details generated during conversion. 
See also Changing line stitch details.
Generated border outlines are created as Satin Line 
objects with the current design settings for width and 
other details. The border is oriented clockwise for 
consistent stitching with objects such as appliqué. 
See also Changing line stitch details.

7 Select thread colors for outlines and/or borders from 
the dropdown lists as required.

8 Click OK.
Click-to-Design converts the artwork to embroidery 
objects and generates stitches.

Try this!  The software matches colors from the 
existing palette. If the design does not seem to convert 
colors properly, check that your monitor is set for 16 Bit 
Colors.

Tool Description
Use Auto Color Reduction to adjust the default 
color count for the processed image. See 
below.
Click Zoom In to zoom into both preview 
panels.
Zoom Out similarly affects both preview 
panels.
Click Show All to display the whole image in 
both preview panels.

Use slider to adjust 
color count or enter 
precise value

3 colors 5 colors

Select thread 
colors from 
dropdown lists
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Chapter 6

Editing Objects

Embroidery objects have certain defining 
characteristics or ‘details’ such as color, 
size, position, and so on. They also have 
settings unique to embroidery such as 
stitch type and density. Details are defined 
when objects are created but they can be 
modified at any time. The most important 
property for an embroidery object is its 
stitch type. Different stitch types are 
suited to different shapes.
This section describes how to select 
objects using the selection tools. It also 
covers modifying object details, including 
line stitch and fill stitch details.

Object types

Embroidery objects divide broadly into two 
categories – Line Stitch and Fill Stitch. Line 
stitching is used for outlines, borders and details, 
while fill stitching is used to fill larger areas of color.

Line stitch objects
Digitizer EXjr supports three styles of line stitch:

Other types of line stitch, such as Motif Run, can be 
opened and viewed in Digitizer EXjr, but details 
cannot be modified.

Fill stitch objects
Larger, closed shapes are known as Parallel Fill 
objects. Most shapes are in fact formed by this 
type of object. Parallel Fill objects can be filled with 
different types of fill stitch. Digitizer EXjr supports 
three styles:

Line Style Purpose
Single Run Single row of run stitches along a straight or 

curved line. Typically used to add outlines or 
details to designs.

Satin Line Satin Line is typically used for borders and 
outlines of larger shapes. Border width can 
be adjusted.
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Other types of fill stitch, such as Motif Fill, can be 
opened and viewed in Digitizer EXjr, but details 
cannot be modified.

Selecting objects in designs

Digitizer EXjr provides various ways to select the 
objects that comprise an embroidery design. You 
can select all objects to modify the design as a 
whole, or individual objects for more precise 
modification.

Selecting all objects in a design
The Select tool provides various means for 
selecting objects including point and click, 
bounding box selection, and – in conjunction with 
Shift+Tab keys – first/last and next/previous 
object selection. You can also select all objects to 
apply changes to a whole design. See also Quick 
Reference.

To select all objects in a design
Select Edit > Select All or press Ctrl+A.
Sizing handles appear around the entire design. 

To deselect, press X or Esc.

Selecting objects by point and click

The simplest way to select objects is by pointing 
and clicking with the mouse with the Select tool 
activated. With Shift and Ctrl keys, you can select 
multiple objects.

To select objects by point and click
1 Click the Select icon.
2 Click the object you want to select.

When you click an object, selection handles appear 
around it. You can click anywhere within these extents 
to click and drag the object.

To select a range of items, hold down Shift as you 
select.
To select multiple items, hold down Ctrl as you 
select.

Line Style Purpose
Satin Fill Satin stitch is well-suited to narrow columns 

and shapes. Satin stitches are almost 
parallel, with every second stitch slightly 
slanted, where the length of each stitch 
forms the width of the column. Because 
there are generally no needle penetrations 
breaking up the fill, Satin stitch creates a 
glossy, high-quality effect.

Weave Fill Weave Fill stitch consists of rows of run 
stitches and is suitable for filling large, 
irregular shapes. Stitches are laid in rows 
going back and forth across the shape. 
These can be parallel or slightly turning.

Embossed 
Fill

Embossed Fill is a decorative stitch type 
used to fill wide and large areas with 
decorative patterns while keeping the 
appearance of a solid field of stitching.

Click Edit > Select and click an object to select it.

All objects selectedNo objects selected

Click an 
object

Hold down Ctrl and 
click another object

Ctrl +
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Try this!  To select an object which is behind another 
object, zoom in and click the outline. Alternatively, 
position the pointer over the object, hold down the 2 
key, and click until the object is selected. Each click 
selects the next overlapping object.

Selecting objects with a bounding box

With the Select tool activated, you can select 
objects by dragging a bounding box around them.

To select objects with a bounding box
1 Click the Select icon.
2 Drag a bounding box around the objects you want to 

select.
Objects are selected when you release the mouse 
button.

Note  Unless they have already been grouped, only 
objects completely within the bounding box will be 
selected when you release the mouse button. See also 
Grouping objects.

Selecting a range of objects by point and 
click

You can select a range of objects by holding down 
Shift while you click the first and last objects in the 
range.

To select a range of objects by point and click
1 Click the Select icon.
2 Click the first object in the range and hold down Shift.
3 Click the last object in the range. 

All objects in the stitching sequence between first and 
last selected objects are selected.

Note  It helps to know the design stitching sequence for 
this method. See Simulating design stitchout for 
details.

Viewing and selecting colors

The Resequence List provides a sequential list of 
embroidery objects as digitized, grouped by color 
block. It offers an easy way to select and view 
colors. It is normally docked on the right but can 
be dragged to any position you require.

Try this!  You can use the Resequence List to lock 
objects as well as flip and rotate them. See also 
Arranging & Transforming Objects.

To view and select colors
Click the Resquence icon.
The Resequence List opens. It can be docked to the 
right side of the design window or floated in any 
position. A separate icon for each color block in the 
design appears in order of stitching sequence.
Click a color corresponding to the color block you want 
to select.

Click Edit > Select and drag a bounding box 
around the object to select.

Click Edit > Select together with the Shift key to 
select a range of objects.

Drag a bounding box 
around the objects

Objects are selected

Use Docker > Resequence to select design 
objects.

Click first object Hold down Shift and 
click last object
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Select more colors as required:
Holding down Ctrl, select multiple objects to 
resequence.
Holding down Shift, select a range of objects to 
resequence.

View selected colors via the View > Show options.

Access commands via the Resequence List including 
lock/unlock and object details.

Warning  Any changes to object details, such as 
flipping, rotating, or changing stitch types, will affect all 
objects in the selected color.

To deselect all objects, click the design window.

Changing object details

Embroidery objects divide broadly into two 
categories – Line Stitch and Fill Stitch. You can 
change the details of selected objects via the 
Object Details dialog.

Changing details of selected objects
You can change the details of selected objects 
individually or as a group. If you select more than 
one object, the Object Details dialog will only 
display tabs that include details relevant to all 
selected objects. If selected objects have different 
current values for the same setting, the field will be 
blank. If you enter a new value, it will apply to all 
selected objects.

Note  Changing the details of existing objects does 
not affect the current or default settings, nor the 
details of any objects not currently selected. See 
also Changing fabrics & backgrounds.

To change details of selected objects
1 Select the object/s whose details you want to change.

Right-click to 
access popup 
menu commands

Values of 
selected objects 

changed
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2 Double-click to open the Object Details dialog.
3 Select the tab you want and adjust details as required.
4 Click OK.

The selected object/s updates according to the new 
details.

Note  All objects have dimensions. These can be 
modified via the Object Details dialog as well. See 
Scaling objects via settings for details.

Changing Parallel Fill details
Larger, closed shapes are known as Parallel Fill 
objects. Most shapes are in fact formed by this 
type of object. Parallel Fill objects can be filled with 
different types of fill stitch. Digitizer EXjr supports 
three styles – Satin Fill, Weave Fill, and Embossed 
Fill. You can change the stitch angle of Parallel Fill 
objects via Object Details.

To adjust Parallel Fill stitch angles by object 
details
1 Select and double-click a Parallel Fill object. See 

Selecting objects in designs for details.
The Object Details > Fill Stitch tab opens.

2 Select the Parallel Fill tab.

3 Enter the required stitch angle in the Fill Stitch Angle 
field.

4 Click OK.

Changing colors of selected objects

Change the color of one or more selected objects 
in your design at any time. You can select all 
objects of the same color with a single command. 
Use this feature to apply a change across all 
objects of the same color. See also Setting up color 
palettes. 

Try this!  When you insert one design in another, 
the two color palettes are merged. See also 
Inserting designs.

To change colors of selected objects
1 Deselect all objects.
2 Click the Color Palette icon or press Ctrl+R.

Double-click to
access object

details

Select
required tab

Adjust details

Position and
scale objects

via these
details Click Docker > Color Palette to open the Color 

Palette. Use this to change colors of selected 
objects or set default color for new objects.

Enter required 
stitch angle

Angle: 90° Angle: 0°
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Try this!  Resize and click-and-drag the color palette 
anywhere within the design window.

3 Update the color palette to use the exact threads you 
want to use as required. See Setting up color palettes 
for details.

4 Select the object (or objects) you want to recolor.
5 Hover the mouse pointer over a color in the color 

palette to view its brand, code and description in a 
tooltip.

6 Select the color you want.
The selected objects update accordingly.

Changing line stitch details

Digitizer EXjr supports two styles of line stitch – 
Single Run Line and Satin Line. Other types, such 
as Motif Run, can be opened and viewed but details 
cannot be modified.

Changing line stitch type
You can change line stitch type at any time. If 
scaling up, you may want to change an outline 
from Run to Satin. See also Scaling objects.

To set Run Line stitch type
1 Double-click the Run Line object.

The Object Details > Line Stitch dialog opens.

2 Select a line stitch type from the dropdown list.

3 Click OK.

Setting Run Line stitch length
For Run Line stitches, set the stitch length to suit 
the digitized shape. Where the object has tight 
curves, select a shorter stitch length. To reduce the 
stitch count for flatter curves, increase the stitch 
length.

Color 
changed

Objects
selected

Single

Stitch Length

654321

Choose line
stitch type
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Note  These values only apply to objects created 
with the Run Line digitizing methods. They do not 
affect travel runs, or underlay stitching.

To set Run Line stitch length
1 Select and double-click a Run Line object. See 

Selecting objects in designs for details.
2 The Object Details > Line Stitch dialog opens.

3 Enter a stitch length in the Stitch Length field.

If a line has tight, sharp curves, reduce the length, for 
example to 1.8mm, so that the stitches follow the line.

4 Click OK.

Setting Satin Line width and density
You can set the exact width of Satin Line columns 
in the Object Details dialog.

To set Satin Line width and density
1 Select and double-click a Line Stitch object – Run or 

Satin. See Selecting objects in designs for details.
The Object Details > Line Stitch dialog opens.

2 Select Satin Line if not already selected.

3 Enter a new width in the Width field.
4 Drag the slider to set the stitch density:

Use a lower density for a zigzag effect.
Use a higher density when using thin thread.

5 Click OK.

Note  If a Satin shape is wide, some stitches may 
exceed the maximum stitch the embroidery machine 
can produce. When the Auto Split setting applied, 
Digitizer EXjr breaks any long Satin stitches into 
shorter ones. It also distributes needle penetrations in 
a random pattern so that they do not form a line in the 
middle of the shape. 

Changing Satin Fill details

Satin Fill creates a glossy, high-quality effect. It is 
well suited to stitching narrow shapes or ‘columns’, 
where each stitch traverses the width of the 
column. Stitch spacing is the distance in 
millimeters between two needle penetrations on 
the same side of a column. Where a column is 
narrow, stitches are tight, thus requiring fewer 
stitches to cover the fabric. Where a column is very 
narrow, stitches need to be less dense because too 
many needle penetrations can damage the fabric. 

Change the stitch density in Satin fills by dragging 
the slider in the Object Details dialog. The larger 
the spacing between stitches, the lower the 
density. The smaller the spacing, the higher the 
density.

To change Satin Fill spacing
1 Select and double-click a Satin Fill object. See 

Selecting objects in designs for details.
The Object Details > Fill Stitch dialog opens.

Adjust stitch
length

Stitch Length: 2.5mm

Stitch Length: 1.7mm

Adjust line
width

Adjust stitch
density

Low density High density

Satin spacing Satin spacing
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2 Move the slider to adjust stitch density:
To increase density, move the slider to the right.
To reduce density for more open stitching, move the 
slider to the left.

3 Click OK.

Note  If a Satin Fill shape is wide, some stitches may 
exceed the maximum stitch the embroidery machine 
can produce. When the Auto Split setting applied, 
Digitizer EXjr breaks any long Satin stitches into 
shorter ones. It also distributes needle penetrations in 
a random pattern so that they do not form a line in the 
middle of the shape. 

Changing Weave Fill details

Digitizer EXjr supports 
three styles of fill stitch – 
Satin Fill, Weave Fill, and 
Embossed Fill. Weave Fill 
stitch consists of rows of 
run stitches and is 
suitable for filling large, 
irregular shapes. You can 
select from many 
attractive Weave Fill 

patterns. Generally the default size and spacing 
will produce the best results, but you may like to 
change the stitch angle.

Note  Other types, such as Motif Fill, can be opened 
and viewed, but details cannot be modified.

Selecting Weave Fill patterns
You can select from various Weave Fill patterns. 
Generally the default size and spacing will produce 
the best results, but you may like to change the 
stitch angle.

To select a Weave Fill pattern
1 Select and double-click a Weave Fill object. See 

Selecting objects in designs for details.
The Object Details > Fill Stitch dialog opens.

2 Click the ‘spin box’ to cycle through a list of patterns, or 
enter the number directly into the field.
A sample appears in the preview panel.

3 Click OK.

Try this!  You can affect pattern orientations by 
adjusting the Parallel Fill angle. See Changing Parallel 
Fill details for details.

Adjusting Weave Fill details
For Weave Fill, stitch density is determined by the 
distance between each row of stitches. The spacing 
setting is the distance between two forward rows. 
You can also adjust Weave Fill stitch length. 

Adjust stitch
density

Density reduced

Density increased

Auto Split ON Auto Split OFF

Select weave
pattern
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To adjust Weave Fill details
1 Select and double-click a Weave Fill object. See 

Selecting objects in designs for details.
The Object Details > Fill Stitch dialog opens.

2 In the Stitch Spacing field, enter the new spacing 
value.
This value is the distance between each forward row of 
stitching.

To increase the density, enter a smaller value.
To decrease the density, enter a larger value.

3 In the Stitch Length field, enter a stitch length.
This setting varies slightly in order to ensure that small 
stitches are not generated at object edges.

4 Click OK.

Creating open weave effects
In Digitizer EXjr, the Travel on Edge feature is 
typically used in combination with open Weave Fill 
stitching to fill backgrounds or for shading effects 
where the absence of travel runs under the fill is 
more important than exact spacing. Travel on Edge 
automatically moves underlying travel runs to the 
edges of an object so they can’t be seen.

To create open weave effects
1 Select and double-click a Weave Fill object.

The Object Details > Fill Stitch dialog opens.

2 With Weave Fill selected as the stitch type, tick the 
Travel on Edge checkbox.
Travel on Edge is automatically checked when Stitch 
Spacing is greater than 0.80 mm or when Gradient Fill 
is selected, but it can be unchecked at any time.

3 Adjust the Stitch Spacing setting as required.
The larger the value, the more open the spacing.

Row spacing

Row direction

Stitch length

Adjust stitch
spacing and

length

Stitch Spacing: 0.4 mm Stitch Spacing: 0.8 mm

Length: 4.5 mm
Minimum Stitch: 0.4 mm

Length: 2.5 mm
Minimum Stitch: 0.4 mm

Adjust Weave
Fill settings

Select Travel on
Edge

Spacing: 3 mmSpacing: 5 mm
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4 Adjust other Weave Fill settings as required. See 
Changing Weave Fill details for details.

5 Click OK.
Travel runs and overlapping rows are removed and 
consistent row spacing applied.

Changing Embossed Fill details

Digitizer EXjr supports three styles of fill stitch – 
Satin Fill, Weave Fill, and Embossed Fill. Embossed 
Fill is a decorative fill stitch in which the needle 
penetrations form a tiled pattern. Select from a 
variety of available patterns.

Note  Other types, such as Motif Fill, can be opened 
and viewed, but details cannot be modified.

Selecting Embossed Fill patterns

You can select from various Embossed Fill patterns. 
Generally the default size and spacing will produce 
the best results, but you may like to change the 
stitch angle.

To select an Embossed Fill pattern
1 Select and double-click an Embossed Fill object. See 

Selecting objects in designs for details.
The Object Details > Fill Stitch dialog opens.

2 From the Pattern dropdown list, select the required 
pattern. 
A sample appears in the preview panel.

3 Click OK.

Adjusting Embossed Fill size and spacing
You can change the size of Embossed Fill patterns 
to get different effects. The spacing setting 
determines the distance between patterns.

To adjust Embossed Fill size and spacing
1 Select and double-click an Embossed Fill object. See 

Selecting objects in designs for details.
The Object Details > Fill Stitch dialog opens.

2 In the Size field, enter the size you require.
3 Click OK.

Select
Embossed Fill

pattern

Adjust pattern
size and
spacing

Size 5.00 mm Size 4.00 mm Size 7.00 mm
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4 In the Spacing fields, enter a new spacing value.
This value is the distance between patterns – X is the 
horizontal and Y the vertical spacing.

To increase spacing, enter a smaller value.
To decrease spacing, enter a larger one.

5 Click OK.

Adjusting Embossed Fill stitch angle
You can change the stitch angle to get the best 
results for each angle. 

To adjust Embossed Fill stitch angle
1 Select and double-click the Embossed Fill object.

The Object Details > Fill Stitch dialog opens.

2 In the Rotate field, enter the rotation angle you require.

Try this!  You can also affect pattern orientations by 
adjusting the Parallel Fill angle. See Changing Parallel 
Fill details for details.

3 Click OK.

Spacing X
decreased

Spacing Y
decreased

Adjust pattern orientation

Rotation Angle 90°Rotation Angle 0°
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Part III
Modifying Designs

After digitizing a design, you can modify it as a whole or even edit individual 
objects.

Combining & resequencing objects
This section describes how to combine objects and designs by copying and 
pasting, duplicating, and inserting techniques. It also describes how to 
resequence objects by cut and paste, by color or object. See Combining & 
Sequencing Objects for details.

Arranging & transforming objects
This section describes how to position objects, lock and group, as well as 
how to scale, rotate, skew, and flip objects. See Arranging & Transforming 
Objects for details.
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Chapter 7

Combining & Sequencing
Objects

Digitizer EXjr lets you add to designs quickly by 
duplicating and copying existing objects. It also 
lets you combine designs by inserting the 
contents of one file into another.
Stitching sequence usually occurs in the order in 
which the design was digitized. However, you can 
change this by a variety of methods.
This section describes how to combine objects 
and designs by copying and pasting, duplicating, 
and inserting techniques. It also describes how 
to resequence objects by cut and paste, by color 
or object. 

Inserting designs

Digitizer EXjr lets you insert one design into 
another. The two (or more) designs can then be 
saved as a combined design.

To insert designs
1 Open the first design.

2 Select Embroidery > Insert Design.
The Open dialog opens.

Use Embroidery > Insert Design to combine two or more 
designs.
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3 From the Look In dropdown list, select the folder where 
the design you want to insert is stored, and select the 
required format from the Files of type dropdown list.

4 Select the design file to insert, and click Open.
The design is inserted at the current needle position.

5 Move the second design into the required position. See 
Positioning objects on screen for details.

Try this!  To ensure that all the objects in the inserted 
design stay together, group the design while working 
with it. See Grouping objects for details.

6 Adjust the stitching sequence as required. See 
Resequencing designs by color for details.

7 Save the combined design under the original or 
different name.
The designs you have inserted are now combined into 
one design.

Try this!  If the two designs share colors, you may want 
to resequence them for efficient stitchout. See 
Resequencing designs by color for details.

Duplicating & cloning objects

A design or design objects can be copied or cut and 
placed on the Windows clipboard for temporary 
storage. It can then be pasted any number of 
times, within either the same or another design, 
until replaced on the clipboard. You can also cut, 
copy and paste lettering objects within and 
between designs. When you insert one design in 
another, the two color palettes are merged.

Copying & pasting objects

You can copy objects to create multiple, identical 
objects, or to insert objects from other designs.

To copy & paste objects
1 Select the object/s to copy.

2 Click the Copy icon.
The selected object is copied to the clipboard.

3 Click the Paste icon.

Move into the 
required position

Adjust stitching 
sequence as 
required

Click Copy (Standard toolbar) to copy selected 
objects to the clipboard.

Click Paste (Standard toolbar) to paste copied 
objects in the design.

Objects copied 
and pasted
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The object is pasted in the design. The object remains 
on the clipboard and can be pasted repeatedly until the 
next Copy or Cut command.

Duplicating objects

Objects can be duplicated rather than copied. 
When an object is duplicated, it is not copied to the 
clipboard. This leaves the clipboard free for you to 
cut or copy other objects.

To duplicate objects
1 Select the object/s to duplicate.
2 Select Edit > Duplicate.

The duplicate object is placed directly on top of the 
original, in the specified position in the stitching 
sequence. 

Warning  Make sure that there is only one copy of an 
object at any one position. If an object is pasted twice 
into the same position, it will be stitched twice.

Cloning objects

The Quick Clone feature lets you quickly duplicate 
selected objects by right-clicking, dragging and 
releasing at a new position.

To clone objects
1 Select an object or objects.
2 Holding down the right mouse button, drag the 

object(s) to a new position.

A black outline of the object appears. The cursor icon 
includes a plus symbol.

Try this!  For more precise positioning, hold down the 
Ctrl key while dragging – movement is thereby 
constrained to X or Y axes.

3 Release the mouse.
A duplicate object(s) is created at the release point.

Try this!  Clone objects to another window by the same 
method. To temporarily deactivate automatic scrolling, 
hold down the Shift key while dragging. An identical 
copy of the selection is created at the same 
coordinates as the first window, no matter where the 
mouse is released.

Deleting objects
Various methods are available for deleting objects.

Select Edit > Duplicate to duplicate selected objects.

Click Edit > Select and click an object to select it.

 Object pasted
then flipped

Duplicated object spacing increased and color 
changed to create blending effect

Right-click 
object

Drag-and-drop

Object 
duplicated

Right-click, hold down Ctrl key, 
and drag-and-drop object Release it
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To delete objects
Select the object/s to delete, and do one of the 
following:

Press Delete.
Select Edit > Delete.

Setting duplication options

The Duplicate feature allows you to create effects 
like drop shadows for lettering or other objects. It 
allows you to add an X and Y offset when 
duplicating. Duplicate objects are placed according 
to settings in the Edit tab of the Work 
Environment dialog.

To set duplication options
1 Select Setup > Work Environment.

The Work Environment dialog opens.
2 Select the Edit tab.

3 Select required Duplicate option:

4 Click OK.

Resequencing designs by color

You can resequence designs by color. This reduces 
the number of color changes required. The 
Resequence List is ‘modeless’ meaning that it 
stays on the design window as long as you need it.

To resequence a design by color
1 Click the Resequence icon.

The Resequence List opens. In the sample below, the 
stitching sequence is labelled. Note that each color is 
stitched twice.

2 Select the first color you want to resequence.
3 Use the dialog buttons to reposition selected color/s in 

the stitching sequence:

Alternatively, click and drag selected colors to the 
required locations.

Select Setup > Work Environment > Edit to set object 
duplication options.

Option Effect

Object 
Position

When activated, cloned objects are 
duplicated in the same location as the 
selected object/s. This is the default 
behavior.

Shift 
Objects

When activated, selected object/s are 
duplicated with horizontal and vertical 
offsets as indicated. Use these to create 
precise offsets for effects such as drop 
shadows.

Select default
object duplication

settings

Click Docker > Resequence to resequence 
objects by color.

Button Purpose

Top: moves it to the start of the sequence.

Up: moves it up one place up in the 
sequence.
Down: moves it one place down in the 
sequence.

Bottom: moves it to the end of the sequence.

Delete: removes it from the sequence.

3
1

5
6

2

4
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4 Repeat as many times as required to optimize the color 
stitching sequence.
Notice in the sample below that color changes have 
been reduced to four – only the purple color still needs 
to be stitched twice.

4
1

5
6

2

3

5
1

4
6

2

3
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Chapter 8

Arranging &
Transforming Objects

You can change the position, size and 
orientation of objects in a design by moving, 
scaling and transforming them. Group objects 
together to apply a change to them all at once, 
or lock them to avoid unintentional 
modification. You can modify objects directly 
on-screen or by changing their settings. You 
can also access some of these functions using 
the popup menu.
The scalability and stitching quality of a design 
ultimately depend on its original source. Only 
native JAN designs contain the complete set of 
design information required for 100% perfect 
scaling and transformation. See also 
Embroidery design formats.
This section describes how to position objects, lock and group, as well as how 
to scale, rotate, skew, and flip objects.

Positioning objects

Position objects in your design using the mouse to 
drag them to a new position, nudging them with 
the arrow keys or by specifying the X:Y coordinates 
in the Object Details dialog.

Positioning objects on screen
The simplest way to move an object in your design 
is to click and drag it to a new position. 
Alternatively, use the arrow keys to ‘nudge’ objects 
into position.

To position objects on screen
1 Select the object/s to move.

2 Click and drag the object to a new position.

3 For more accurate positioning, press the arrow keys to 
‘nudge’ the object into the required position.

Cross-hair cursor 
centers objects
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Try this!  Zoom in to make small adjustments. The 
distance the object moves depends on the current 
zoom factor. The greater the zoom factor, the smaller 
the distance moved.

Positioning objects via settings
You can position selected objects relative to the 
center of a design by entering its X:Y coordinates 
in the Object Details dialog.

To position objects via settings
1 Select the object/s to move.
2 Double-click the object to open the Object Details 

dialog, and select the Dimensions tab.

3 Enter the new object coordinates in the Position fields.
4 Click OK.

The object is centered over the coordinates you set.

Locking & grouping objects

When you lock objects, you can prevent them from 
being moved or modified by accident. When you 
group objects, you can apply a change to all 
objects at once, saving time, and ensuring that the 
change is consistent across all.

Locking objects

Lock objects to prevent them from being moved or 
modified by accident. For example, locking 
backdrop images or vector drawings holds them in 
place as you manipulate embroidery objects 
around them. Locked objects can be unlocked for 
modification at any time.

To lock objects
Select the object you want to lock and select Edit > 
Lock.

The selection handles disappear, indicating that the 
object can no longer be selected or modified.
To unlock objects, select Edit > Unlock.
All locked objects in the design are unlocked. 

Try this!  Right-click the selected objects and select 
lock from the popup menu.

Grouping objects
You can group selected objects or the whole design 
to keep them together for moving, scaling and 
transforming actions.

To group objects
1 Select the objects to group.
2 Select Edit > Group.

Selected objects are combined into a group. This can 
be selected, moved, resized and transformed as a 
single object.

Try this!  To select with a bounding outline, simply drag 
the outline over one component object and the whole 
group will be selected. See also Selecting objects with 
a bounding box.

Ungrouping objects

When you have finished making changes to a 
group, you can ungroup it and work with the 
objects individually.

Note  You need to ungroup before you can set 
embroidery details for any individual object in the 
group.

To ungroup objects
1 Select the grouped object.
2 Select Edit > Ungroup.

Select Edit > Lock to lock selected objects. Select Edit > 
Unlock to unlock objects.

Enter new 
coordinates

Select Edit > Ungroup to ungroup selected objects.

Select, move, resize, 
transform grouped 
objects as a single object
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The object is ungrouped, and the component objects 
selected.

Scaling objects

You can scale objects by dragging the selection 
handles with the mouse, specifying the exact 
dimensions in the Object Details dialog, or by 
setting the distance between reference points on 
the design. As an object is scaled, the stitch count 
changes to preserve the current stitch spacing.

Note  Only native JAN designs contain the complete 
set of design information required for 100% 
perfect scaling and transformation. 

Scaling objects on screen
You can change the height and width of an object, 
or scale it proportionally using the selection 
handles. Scale objects individually, or select 
multiple objects and scale them together.

To scale objects on screen
1 Select the object/s to scale.

Eight selection handles appear around the object.
2 Click and drag a selection handle to resize the object.

To scale height and width proportionally, use a corner 
handle.

To change the height, use the handles at the 
center-top or center-bottom.

To change the width, use the handles at the 
center-sides.

Try this!  To resize around a center anchor, hold down 
Shift while you resize.

Scaling objects via settings
You can scale selected objects or a whole design 
using Object Details. This allows stitches to be 
regenerated and the original stitch density 
preserved.

Warning  If you scale a stitch design by more than 
5%, changes to stitch density will affect the design 
quality. See also Embroidery design formats.

To scale objects via settings
1 Select the object/s to scale.
2 Double-click the object to open the Object Details 

dialog, and select the Dimensions tab.

Ungrouped objects can be 
selected individually

Object is ungrouped, 
component objects selected

Scale proportionally Scale proportionally 
about center

Shift+dragDrag

Scale vertically

Drag

Scale horizontally Scale horizontally

Drag

Shift+drag

Scale 
vertically in 
both 
directions

Scale horizontally in 
both directions

Shift+drag

Adjust height and 
width values
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3 In the Dimensions panel, scale the object as required. 
Either:

Enter exact height and width values
Enter the new height and width as a percentage of 
the current dimensions.

4 Click OK.

Note  After scaling, the new object size is reset to 
100%.

Rotating objects

You can rotate objects directly on-screen or by 
using the Rotate tool.

Rotating objects on screen
When you select an object, selection handles 
display at its extremities. If you click the object 
again, the handles change to rotation handles.

To rotate objects on screen
1 Select the object/s to rotate.
2 Click the object a second time.

Rotation handles appear at the corners of the object 
and an anchor point displays at the object’s center.

Note  If you click too quickly, the Object Details dialog 
opens.

3 If required, drag the rotation anchor from the center to 
a new position.

4 Click a rotation handle, and drag it clockwise or 
anti-clockwise. An outline and cross-hairs display as 
you rotate.

Try this!  You can also rotate objects by a precise 
angle via the Object Details dialog. Double-click the 
object and select the Dimensions tab. Enter the 
rotation angle and click OK.

Rotating objects using Rotate

Use the Rotate 45° CCW/CW tool to rotate 
objects by 45° rotations in either direction.

To rotate objects using Rotate
1 Select object/s with the Select tool.

2 Click Rotate 45° CCW/CW on the toolbar. 
Click to rotate 45° counter-clockwise.
Right-click to rotate 45° clockwise.

Try this!  You can also access the commands via the 
Resequence List. See also Resequencing designs by 
color.

Original
object

Height scaled
by 150% Height scaled by 50% 

width scaled by 125%

First click displays 
selection handles

Second click displays 
rotation handles

Anchor point

Skew handle

Rotation handle

Click Edit > Rotate 45° CCW/CW to rotate a 
selected object or design by 45° clockwise. 
Right-click to rotate by 45° counter-clockwise.

Drag a corner to 
rotate about the 

anchor point

Drag the anchor 
point

Drag a corner to 
rotate about the 

anchor point

Adjust rotation 
angle
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Skewing objects

You can skew objects along the horizontal plane by 
clicking skew handles and dragging to the required 
angle.

To skew objects
1 Select the object/s to skew.
2 Click the object a second time.

Rotation and skew handles appear around the object. 
Skew handles are diamond-shaped and appear at the 
center-top and bottom of the object.

3 Drag the skew handles left or right.
The object skews along the horizontal plane. An outline 
and cross-hairs show the change to the object’s shape.

Flipping objects

You can flip selected objects horizontally or 
vertically using the dedicated tools.

To flip objects
Select the object/s to flip.

Click the Flip Horizontally tool to flip the object 
left/right.
Click Flip Vertically to flip up/down.
Alternatively, right-click the object and select Flip 
Horizontally or Flip Vertically from the popup menu.

Try this!  You can also access the commands via the 
Resequence List. See also Resequencing designs by 
color.

Creating ornamental layouts

The Easy Layout feature allows you to arrange 
multiple embroidery designs on the item or fabric 
to be sewn. You can create a large embroidery 
layout using Easy Layout and any selected 
design/s or object/s. Designs are automatically 
copied, rotated and placed in the work area 
according to the chosen transformation method.

Click Edit > Flip Vertically to flip a selected object 
or design up/down.

Click Edit > Flip Horizontally to flip a selected 
object or design left/right.

Right-click to 
access popup 
menu commands

Drag skew handle 
left or right

Flip in both directionsFlip vertically

Source object Flip horizontally

Right-click to 
access popup 
menu commands
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You can also print out the layout with Cloth Setter 
marks to enable them to use the Cloth Setter to 
physically layout the designs on the item or fabric 
you wish to embroider. You can also print the 
template which can be used to position each of the 
hooped portions of the design. See Printing 
Designs for details.

Try this!  When used in conjuction with the Combine 
toolbar, you can place multiple hoops in a single 
design. See Hooping large designs for details.

Defining work areas

Before you can create a design layout, you first 
need to define a work area according to the 
characteristics of the item or fabric you intend to 
sew to. Work areas may be defined as rectangular 
or circular spaces. Digitizer EXjr allows you to 
define a work area of up to 3m x 3m.

To define a work area
1 Click the Define Layout Work Area button to create a 

new work area.
The Easy Layout Work Area dialog is displayed.

2 Select either a rectangular or round work area and 
enter the required size.

3 Optionally click the color droplist to change the display 
color.

4 Optionally, click More Colors to select another color or 
create a new color of your choice.
The Colors dialog opens.

5 Click OK to confirm selections.
6 Click the Display Layout Work Area button to display 

the layout.

Use Easy Layout > Display Layout Work Area to 
toggle display of the defined work area.

Use Easy Layout > Define Layout Work Area to 
access the Easy Layout Work Area dialog.

Use Apply to generate the object/s and stitches of 
copies created by Easy Layout operations. 
Pressing the Enter key has the same effect.

Define rectangular or
circular work area

Define work
area color

Change display
color

Pick or define 
color of your 
choice
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Creating layouts

Create large embroidery layouts using Easy 
Layout together with selected design/s and/or 
object/s. Designs are automatically copied, rotated 
and placed in the work area according to the 
chosen transformation method. Designs are 
always placed equidistant around the center of the 
work area based on the reference design/s or 
object/s – i.e. the design/s or object/s selected to 
perform the operation.

Note  There is no merging of overlapping designs 
and there is no optimization of color changes.

To create a layout
1 Define a work area as required, and click the Display 

Layout Work Area icon. See also Defining work areas.
2 Insert a design and/or select a design/s or object/s 

already on-screen.
3 Move them to the desired position in the work area.

Warning  If you want the selected objects to sew out in 
separate hoopings, make sure they are grouped before 
proceeding. Otherwise, they will be color-optimized for 
a single stitchout – i.e. color block by color block. See 
also Hooping large designs.

4 Click the Copy And Mirror To Corners tool.
Four wireframe copies are displayed and placed 
equidistant around the center of the work area. Each 
copy is mirrored about the vertical or horizontal plane 
depending on the location of the reference design.

5 Click the Apply button or press Enter to confirm.
6 Insert or create additional designs as required.

Use Easy Layout > Copy And Mirror To Corners 
to automatically create copies of any selected 
object/s in each corner of the layout work area.
Use Easy Layout > Move To Center to 
automatically move selected object/s to the 
center of the work area.
Use Apply to generate the object/s and stitches of 
copies created by Easy Layout operations. 
Pressing the Enter key has the same effect.



Digitizer EXjr Instruction Book
Chapter 8 Arranging & Transforming Objects

65

7 Use the Move To Center tool to automatically move 
selected object/s to the center of the work area. 

8 Press Enter to confirm.
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Part IV
Embroidery

Lettering

Create top-quality lettering quickly and simply. Digitizer EXjr provides a 
large range of scalable closest-join alphabet styles and multi-color and fancy 
stitching alphabets to choose from.

Creating embroidery lettering
This section describes how to add lettering, change formatting settings, and 
set lettering orientation. It also covers adding special characters as well as 
the creation of monogram designs. See Creating Embroidery Lettering for 
details.

Editing embroidery lettering
This section describes how to edit lettering including stitch type and letter 
spacing. It also covers scaling and transforming lettering. See Editing 
Embroidery Lettering for details.
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Chapter 9

Creating Embroidery
Lettering

Digitizer EXjr lets you add lettering to 
designs quickly and easily using the built-in 
library of embroidery fonts. Apply 
formatting to lettering objects in the same 
way as a word processor, including italics.
Orientation determines the shape of 
lettering objects in a design. You can place 
lettering on a straight horizontal or vertical 
baseline, curve lettering around a circle or 
arc baseline, or digitize your own. 
Digitizer EXjr gives you interactive control 
over many baseline settings.
Embroidery fonts generally contain many 
more characters than are available via your 
keyboard. Use the Windows Character Map 
to provide quick access to special characters 
and symbols. 
Create monogram designs using special monogramming fonts. These provide 
three sets of the upper-case alpha characters.
This section describes how to add lettering, change formatting settings, and set 
lettering orientation. It also covers adding special characters as well as the 
creation of monogram designs.
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Adding lettering to embroidery 
designs

Digitizer EXjr lets you add lettering to designs 
quickly and easily using the built-in library of 
embroidery fonts. Apply formatting to lettering 
objects in the same way as a word processor, 
including italics.

Creating embroidery lettering

You can change lettering characteristics before or 
after you digitize. You can also modify lettering 
objects directly on-screen to achieve various 
artistic effects. Digitizer EXjr provides a font range 
suitable for many applications.

To create embroidery lettering
1 Click the Lettering icon.

The Object Details > Lettering dialog opens.

2 Enter the text you want to embroider in the text entry 
panel.
To start a new line of lettering, press Enter. 

Try this!  You can insert a color change between two 
letters by keying a caret (^) symbol. Subsequent letters 
default to the next color in the palette.

3 Select a font from the Font list.
A sample character of the chosen font appears in the 
preview window. For samples of the complete selection 
of standard fonts, see Packaged Fonts.

4 Adjust the lettering Size, Width, and Slant settings as 
required. See also Editing Objects.

Try this!  Consider the font before changing letter size. 
Some fonts look best in a smaller size. Others can be 
stitched at a larger size. See also Packaged Fonts. 

5 Select a lettering orientation. See Setting lettering 
orientations for details. 

6 Click OK.
7 Click where you want to place the lettering, or mark 

reference points for the selected baseline.
8 Press Enter.

Note  Letters are filled with stitches according to 
current settings in the Fill Stitch tab of the Object 
Details dialog. You can change these at any time. See 
Changing lettering stitch types for details.

Use Lettering > Lettering to add embroidery 
lettering to designs or edit selected lettering.

Enter text

Select
orientation

Select font
and format
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Adding special characters

You can quickly add special characters and 
symbols to your lettering designs. If you know the 
keyboard shortcut for a symbol, add it to your 
lettering by entering the combination on-screen or 
in the Object Details > Lettering dialog.

To select special characters
1 Right-click the Lettering icon.

The Object Details > Lettering dialog opens.

Try this!  If you know the Alt key code for the special 
character you require, you can key it directly into the 
text entry field. The Windows Character Map gives you 
codes for all characters.

2 Click Insert Symbol.
The Select Symboldialog opens.

Try this!  Select a viewing mode – you can list fonts by 
picture, character, or both.

3 Select a font from the Symbol Set list.
4 Select the character(s) you want to use. 

Try this!  When you select a character, a keystroke 
appears in the Selection field. This indicates the key 
combination required to type the character directly 
on-screen. For example, ‘m’ means press the m key 
while ‘M’ means press Shift+M.

5 Click OK to close the dialog.
The selected characters are displayed in the text entry 
panel. See Creating embroidery lettering for details.

Setting lettering orientations

Orientation determines the shape of lettering 
objects in a design. You can place lettering on a 
straight horizontal or vertical baseline, curve 
lettering around a circle or arc baseline, or digitize 
your own. Different reference points are needed 
depending on the orientation you use.

Baselines use default settings to determine their 
size, spacing and angles. Digitizer EXjr gives you 
interactive control over many baseline settings. 
Techniques are available to modify baseline type, 
length, radius and angle, as well as baseline 
position.

Selecting lettering orientation

You can select different orientation through the 
Object Details dialog. You can also adjust 
baseline settings. You can apply orientation to new 
or selected objects.

Click Lettering > Lettering to add lettering directly 
on-screen.

Click to select special 
characters

Select font

Select
character

Corresponding
keystrokes

Select viewing mode

Click Lettering > Lettering to select orientation 
and adjust baseline settings.
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Try this!  Create identical baselines by duplicating 
or copying them in your design.

To select a lettering orientation
1 Double-click a selected lettering object.

The Object Details > Fill Stitch dialog opens.
2 Select Lettering tab.
3 In the Orientation panel, click an orientation icon.

The orientation you choose depends on the effect you 
want to achieve. You need to digitize different 
reference points depending on the type selected. 
Options include:

Horizontal: See Creating horizontal orientations for 
details.
Vertical: See Creating vertical orientations for details.
Any Shape: See Creating custom orientations for 
details.
Circle CCW: See Creating circular orientations for 
details.
Circle CW: See Creating circular orientations for 
details.

4 Click OK.

Creating horizontal orientations
Free Line baselines are straight, horizontal 
baselines. Free Line does not have a fixed or 
pre-determined length – the baseline extends as 
long as you keep adding letters.

To create a horizontal orientation
1 Create a new lettering object. See Creating embroidery 

lettering for details.

2 In the Object Details > Lettering dialog, select Free 
Line as the orientation.

3 Click OK and click on-screen to establish the start-point 
of the baseline.

Creating vertical orientations
Vertical orientation does not have a 
fixed or pre-determined length – the 
baseline extends as long as you keep 
adding letters. Line spacing is 
calculated horizontally while letter 
spacing is calculated vertically. 
Letters, by default, are centered 
along vertical lines. New lines are 
placed by default from right to left to 
suit Asian languages. Vertical 
orientation is effective for 
embroidering on sleeves, as a 
decorative effect, and for Asian text.

Try this!  Vertical lettering best suited 
to uppercase for Western languages 
because descenders in lowercase 
letters are not accommodated in the 
letter spacing.

To create a vertical orientation
1 Create a new lettering object. See Creating embroidery 

lettering for details.
2 In the Object Details > Lettering dialog, select 

Vertical as the orientation.

3 Enter your text in the text entry box.
4 Click OK and click on-screen to establish the start-point 

of the baseline.

Creating circular orientations
Use the Circle CCW or Circle CW orientation to 
place letters around a full circle. 

Select an
orientation

Free Line
baseline

Select
vertical

orientation
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For a circle you need to mark two reference points, 
while for an oval you need to mark three. The 
position of the second reference point determines 
the justification point of the text. The text is 
centered around this point. 

To create a circular orientation
1 In the Object Details > Lettering dialog, click the 

Circle CCW or Circle CW orientation icon as required.

2 Enter your text in the text entry box.
3 Click OK.
4 Mark the center of the circle on-screen.
5 Mark a point on the circumference to define the radius.

6 Press Enter for a perfect circle, or click again to form 
an oval.

7 Press Enter to close the oval.
The letters of your text are positioned around the circle 
according to the chosen orientation – Circle CCW or 
Circle CW.

Note  Orientation of the text around the oval is affected 
by both orientation method and where you mark the 
reference points.

Creating custom orientations
Use Free Line orientation to shape lettering around 
elements in your design. Digitize Free Line 
baselines by marking reference points to form the 
required line. The number of reference points and 
length of baseline are practically unlimited.

Try this!  If the baseline has tight curves, or sharp 
corners, the letters may overlap. For best results, 
only mark curve points, and digitize lines which 
have shallow, gentle curves.

To create a custom orientation
1 In the Object Details > Lettering dialog, click the Any 

Shape orientation icon.

Select circular orientation

Click to place
center of circle

Click to set radius 
of circle

1 2

Click to place
center of circle

Click to set 
radius of circle

1 2

3
Click to set radius 
of oval
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2 Enter your text in the text entry box.
3 Click OK.
4 Mark the baseline reference points.

Mark curve points with the right mouse button.
Mark corner points with the left mouse button.

5 Press Enter to complete.

Creating monogram lettering

The Monogramming tool allows you to create 
personalized monograms with up to three initials, 
including special characters and symbols, or 
unlimited lines of characters.

Creating monogram lettering with 
initials

Up to three initials can be entered into your 
monogramming design, including special 
characters and symbols. Change settings for each 
one or all together, or apply pre-defined layout 
styles.

To create monogram lettering with initials
1 Click the Monogramming icon.

The Monogramming dialog opens with the Lettering 
tab selected. The Initials option is selected by default.

Note  The All Letters option is selected by default. 
This means that any changes to lettering properties will 
affect all initials in the monogram. If you want to specify 
different settings for each one, select the button 
corresponding to the letter you want to modify before 
proceeding. This step is repeated for each letter.

2 Enter the first initial for the monogram in the Letter #1 
field.
The letter simultaneously appears in the design 
window.

Note  When using a single letter, it should be placed in 
the Letter #1 field.

3 Tab to the next fields and enter second and third initials 
as required.
These letters appear in the design window.

Use Lettering > Monogramming to create 
personalized monograms using a selection of 
pre-defined styles, border shapes and 
ornaments.

Select Any Shape orientation

1

2

3

4

Enter initials in 
each field
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4 Optionally, click the Style button and select the style 
you want from the flyout menu – scroll to the desired 
item and release the mouse button.
The current height of Letter #1 is used as the ‘base 
setting’ for the style.

Note  The Style button is only applicable to initials. 
(Style 1 is applied by default.) When the Name option 
is selected, this button is disabled. See also Creating 
monogram lettering with names.

5 Use the Alphabet dropdown list to change alphabets 
and adjust the Letter Height setting as required.

Note  The default values for monogram lettering 
Alphabet and Height are distinct from those for 
conventional lettering.

6 Click Modify Details to make any further adjustments 
to your lettering stitch properties. See Changing 
lettering stitch types for details.

7 Click OK to complete.

Note  The zoom factor is automatically adjusted to 
show the whole monogram.

Creating monogram lettering with 
names

The monogram Name option allows unlimited lines 
of characters to be entered.

To create monogram lettering with a name
1 Click the Monogramming icon.

The Monogramming dialog opens with the Lettering 
tab selected. The Initials option is selected by default.

2 Click the Name option.
The Initials option is disabled.

3 Enter your text in the Name field.

Enter initials in 
each field

Select layout style 
from flyout menu

Style 1

Style 15

Style 7

Select alphabet

Adjust lettering
settings

Adjust letter height

Use Lettering > Monogramming to create 
personalized monograms using a selection of 
pre-defined styles, border shapes and 
ornaments.

Style 1 with default 
properties

Italic 35%

Width 130%
Vertical baseline

Select Name
option

Initials option
disabled



Digitizer EXjr Instruction Book
Chapter 9 Creating Embroidery Lettering

74

Pressing Enter starts a new line. When more than one 
line is created, the default baseline type is used.

4 Click the Insert Symbol button if you want to add 
special characters and symbols. See Adding special 
characters for details.

5 Select a thread color from the Color field.

Try this!  You can edit the name using Backspace or 
Delete keys, using left and right arrow keys, or Home 
and End keys to move the insertion point.

6 Use the Alphabet dropdown list to change alphabets 
and adjust the Letter Height setting as required.

Note  The default values for monogram lettering 
Alphabet and Height are distinct from conventional 
lettering.

7 Click Modify Details to make any further adjustments 
to your lettering stitch properties. See Editing 
Embroidery Lettering for details.

8 Click OK.
The monogram lettering object is added to the design 
window, replacing any that might already be there. 

9 Click OK to complete.

Select
alphabet

Click to adjust
lettering settings

Click to add special
character

Click to create
lettering

Slant - 45

Circle CW baseline Font changed

Selected font with default settings
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Chapter 10

Editing Embroidery
Lettering

Digitizer EXjr gives you interactive and 
precise numeric control over many settings 
affecting lettering objects. You can adjust 
lettering objects as a group as well as the 
individual letters comprising a lettering 
object. Letter and line spacings can be 
determined before or after creating 
lettering objects and placing them in your 
design.
When you first create lettering, it may be 
too big or too small. Size can be adjusted 
both interactively and via settings. Apart 
from scaling, you can interactively skew 
and rotate lettering objects. 
This section describes how to edit lettering 
including stitch type and letter spacing. It 
also covers scaling and transforming 
lettering.
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Editing lettering

When you have created a lettering object, you can 
select it and make changes to it directly on-screen 
or by adjusting object details.

To edit lettering
Select a lettering object, and click the Lettering icon.
An I-beam appears after the last letter of the object. 
You can move it using arrow keys.

Edit the text as required:
Use the arrow keys to move between letters.
Use Backspace and Delete keys to remove letters.
Press Enter to complete.

Try this!  Press Shift+Enter to start a new line.
With the lettering object selected, change fonts by 
selecting another font from the Font list on the 
Lettering toolbar.

Adjust lettering Size and Width settings as required. 
See also Scaling lettering.

Change slant settings as required.

Change orientation settings as required. See Setting 
lettering orientations for details.

Try this!  Alternatively, double-click a selected lettering 
object or objects. The Object Details > Fill Stitch 
dialog opens. Select the Lettering tab and edit settings 
as required.

Click Lettering > Lettering to edit lettering 
on-screen.

Select font

Adjust Size and Width 
settings

Change 
orientation

Change
slant
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Note  Letters are filled with stitches according to 
current details in the Object Details > Fill Stitch tab. 
See also Changing lettering stitch types.

Changing lettering stitch types

By default, lettering objects are filled with Satin 
Fill. You can also apply other fill stitch types, such 
as Weave Fill and even Embossed Fill, as with 
other embroidery objects. See Editing Objects for 
details.

To change lettering stitch types
Double-click a selected lettering object.
The Object Details > Fill Stitch dialog opens.

To adjust Satin settings, move the slider to adjust the 
lettering stitch density.
By default, lettering objects are filled with Satin Fill. 
Where a letter is narrow, stitches are tight, thus 
requiring fewer stitches to cover the fabric. Where a 
column is very narrow, stitches need to be less dense 
because too many needle penetrations can damage 
the fabric. See also Changing Satin Fill details.

Select a Weave Fill and adjust settings as required.
Weave Fill is suitable for large, irregular lettering 
shapes. See also Changing Weave Fill details.

Try this!  You can even select from various Embossed 
Fill patterns. Generally these are only suitable for 
large, block lettering objects. See Changing Embossed 
Fill details for details.

Scaling lettering

When you first create lettering, it may be too big 
or too small. Size can be adjusted via:

Resize handles available with the Select tool,
Size and height settings in the Lettering 
toolbar,
Size and height settings in the Object Details 
> Lettering dialog, or
Width and height settings in the Object Details 
> Dimensions dialog.

Try this!  You can change the appearance of a font 
by changing the letter width in proportion to the 
height. The original width value is 100%.

Edit text

Adjust
details
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Scaling lettering on screen

You can scale your lettering objects vertically, 
horizontally and proportionally with the Select 
tool. See also Transforming lettering.

To scale lettering on screen
1 Click the Select icon and select the lettering object.

2 Click and drag one of the square control points to 
resize the object horizontally, vertically or 
proportionally.
A shadow outline shows the new size of the lettering 
object as you drag.

3 Release the mouse to complete.

Try this!  Alternatively, adjust lettering Size and Width 
settings via the Lettering toolbar. See Editing lettering 
for details.

Scaling lettering via settings
You can scale your lettering objects vertically, 
horizontally and proportionally via the Object 
Details > Lettering tab or Object Details > Dimensions 
tab. The Dimensions tab is easier for scaling height 
and width settings independently of each other.

Try this!  You can change the appearance of a font 
by changing the letter width in proportion to the 
height. The original width value is 100%. 

To scale lettering via settings
1 Double-click selected lettering object/s.

The Object Details > Fill Stitch dialog opens.
2 Select the Lettering tab.

3 Enter the size of your lettering object in the Size field.
4 Enter the width of your lettering object in the Width field 

as a percentage of the height. 
For wide letters, increase the percentage – e.g. 
140%.
For narrow letters, decrease the percentage – e.g. 
70%.

Use Edit > Select to scale lettering objects 
on-screen.

Resize 
Horizontally

Resize 
Proportionally

Resize Vertically

Drag

Adjust Size and Width 
settings

Typist

Enter letter
size and width



Digitizer EXjr Instruction Book
Chapter 10 Editing Embroidery Lettering

79

Try this!  Alternatively, select the Dimensions tab and 
adjust width and height settings either as absolute 
values (mm) or as a percentage of current settings.

Transforming lettering

You can transform lettering objects by 
manipulating control points on-screen with the 
Select tool. See also Scaling lettering on screen.

To transform lettering
1 Click the Select icon and select the lettering object.

The resizing control points appear. See also Scaling 
lettering on screen.

2 Click the lettering object again.
Another set of control points appear. These let you 
rotate and skew the lettering object.

3 Click and drag one of the diamond-shaped control 
points to skew the lettering object horizontally.
A shadow outline shows the skewed lettering object as 
you drag.

4 Click and drag one of the hollow square control points 
to rotate the lettering object.
A shadow outline shows the rotated lettering object as 
you drag.

5 Click and drag the rotation point itself to a new position 
before rotating.

6 Press Esc to complete.

Use Edit > Select to transform lettering objects 
on-screen.

Adjust width and
height details

Skew handle

Rotation point

Rotation 
handle

Drag

Drag

Rotation point 
moved
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Part V
Design Processing

You can output embroidery designs in a variety of ways – saving to disk or 
sending directly to machine for stitching. Designers frequently want to 
distribute their designs so that they can be seen in real colors, in Visualizer 
or otherwise. In Digitizer EXjr you can save both design images and 
production worksheets to disk or email them.

Printing designs
This section describes how to preview printouts, set print options, print 
embroidery elements, appliqué patterns, as well as color layers. See 
Printing Designs for details.

Reading & writing design files
This section describes embroidery stitch and outline design formats, as well 
as how to open embroidery files in Digitizer EXjr. It also describes saving 
designs for machine as well as sending and receiving designs by direct 
connection. Writing designs to an external media drive is also covered. See 
Reading & Writing Design Files for details.
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Chapter 11

Printing Designs

You can create a hard copy of 
your designs using default or 
custom printer options. 
Preview designs before 
printing. Set print options to 
display the exact information 
you require. There are options 
to include or exclude start/end 
point crosshairs, connectors, 
background color/fabric as well 
as the current hoop. Print a 
copy of the appliqué pattern to 
use to cut out the fabric pieces. 
A Color Layers option allows 
you to include a list of color 
layers together with color and stitch information for each layer. If you are using 
a color printer, you can print in Visualizer mode.
This section describes how to preview printouts, set print options, print design 
elements, appliqué patterns, as well as color layers.

Previewing printouts

Use Print Preview to view stitching information. 
Use it to check the sewing sequence before you 
stitch out your design. You can create a hard copy 
of your designs using default or custom printer 
options.

To preview a printout
1 Click the Print Preview icon.

Your design displays as it will be printed. Large designs 
may be displayed over a number of pages if printed at 
actual size.

Use Standard > Print Preview to preview a design 
printout.

Use Standard > Print to print a design using 
current settings.
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2 Use the Preview buttons as required:

3 Click Options to set any Print Options. See Setting 
print options for details.

4 Click Print Now to proceed with printing.
The MS Windows® Print dialog opens allowing you to 
choose a printer and adjust any other print settings you 
require. See also Setting print options.

5 Click Close to return to the design window.

Setting print options

Print options give you precise control over your 
design printout. You can include templates or 
designs, design elements, and cloth setter 
markings. You can include a copy of the appliqué 
pattern as well as a list of color layers in the 
current design. Design information includes 
author, estimated length of upper thread per color 
and total bobbin usage.

To set print options
1 To access the Print Options dialog, either select File 

> Print or File > Print Preview.

2 Click Options.
The Print Options dialog opens.

3 Click a Design or Template mode button to pre-set the 
design worksheet display options.

4 Select additional worksheets to include in the printout 
as required:

Check Color Layers for a list of colors in the design, 
together with color and stitch information for each 
color layer. See Printing color layers for details.
Check Appliqué Patterns if you want a copy of the 
appliqué pattern as a guide to cutting out fabric 
pieces. See Printing appliqué patterns for details.
Check Hooping List if there is more than one 
hooping in the design. This displays hoopings in their 
correct color sequence. See Printing multi-hooped 
designs for details.

5 Select a sizing option from the Design Size panel.
This option applies to both Template and Design 
modes. When selecting Template mode, the Actual 
Size option is automatically selected.

Button Purpose
Next Page View the next page.
Prev Page View the previous page.
Two Page Display two pages in the Preview 

Window.
Portrait / 
Landscape

Toggle design display between 
landscape and portrait views.

Zoom In/Out Use to examine portions of the design 
or to read production information.

Mode Purpose
Design 
Mode

Shows the design as it appears in the 
design window. You can turn on or off the 
preset options as required. See also 
Printing design elements.

Template 
Mode

Shows the design outlines with no 
stitches. See also Printing design layouts.

Select design
elements to print

Click a mode to
pre-set design

worksheet
display options
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6 Click OK.

Note  While the cloth setting marking is supported in 
JEF and SEW files, outlines are not. Since JEF and 
SEW are stitch file formats, they only contain stitch 
data, no outlines. The workaround is to display JEF and 
SEW files with stitches and cloth setter marking turned 
on.

Printing design elements

If you choose to print the Design Worksheet, 
there are options to include or exclude start/end 
point crosshairs, connectors, background 
color/fabric as well as the current hoop. Design 
information includes author, estimated length of 
upper thread per color and total bobbin usage.

Try this!  Using Design Worksheet options, you 
can also choose to print only design outlines 
without stitch information. You can also print only 
design images – vector or bitmap – as desired.

To print design elements
In the Print Options dialog, select the Design 
Worksheet option if not already selected. See Setting 
print options for details.

Choose the Stitches option if you want to include stitch 
data in your worksheet. Further options include:

Visualizer: Choose this option to print a 
representation of the final embroidery.

Connectors: All connecting stitches in the design 
are displayed, including jumps.

Note  With Visualizer on, the Connectors option only 
shows actual connecting stitches. It does not show 
jumps which are displayed in normal stitch view.
Include or exclude other design elements as required:

Image: If you want to include any bitmap images in 
the printout, select this option – e.g. design 
backdrop. See also Digitizing with Artwork.

Actual Size

Fit to Page

Select design
elements to print

Select Design
Worksheet
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Outlines: Select if you want to highlight design 
shapes with a dark outline. These are more obvious 
with Visualizer turned off. Alternatively, print design 
outlines with no stitches showing. See also Printing 
design layouts.
Vectors: If you want to include any vector graphics 
in the printout, select this option. See also Digitizing 
with Artwork.

Hoops: If you want to include a representation of the 
hoop in the printout, select this option. Not to be 
confused with the Hooping List used for multi-hooped 
designs. See also Printing multi-hooped designs.

Check the Cloth Setter Marking as required. 
Cloth setter marks are printed for each hooping in the 
design. These allow accurate placement of designs 
within layouts on the item or fabric to be sewn. See also 
Printing design layouts.

Check Work Area to include an outline of the work 
area on the worksheet. See Creating ornamental 
layouts for details.

Try this!  When printing a large layout the software will 
display a warning dialog if the number of pages needed 
for the printout exceeds 10. Use the Fit To Page option 
or choose a % of Actual size to reduce the page count.
Check the Grid option to include the background grid 
on the worksheet. See also Measuring distances on 
screen.
If you want to include the Background Color/Fabric, 
select this option. See also Changing fabrics & 
backgrounds.
Start/End Crosshairs: If you want to include start and 
end needle positions, select this option. The green 
crosshairs indicate the start point of the design, while 
the red crosshairs, the end point. By default, the green 
crosshairs are usually set to the center of the hoop.

Check Embroidery Information to toggle the display 
of embroidery details on/off. In Template mode, 
detailed information is excluded from the worksheet by 
default.

Printing design layouts

You can sew embroidery out by sending the design 
directly to a sewing machine or saving it to 
removable media and stitching out using a layout 
template and the cloth setter. The device has a 
transparent plastic bar with marked cross.

Printing in Template Mode shows the design 
outline with no stitches. You can include cloth 
setter marks to allow accurate placement of 
designs within predefined layouts on the item or 
fabric to be sewn. These allow you to position the 
device for accurate design centering within a hoop.

Printing large layouts
Digitizer EXjr allows you to define layout work 
areas of up to 3m x 3m. Large layouts may print to 
many pages. To save paper, you may choose to 
print at a percentage of actual size. You must then 
remember to multiply the template dimensions by 

Cloth setter marking displayed

Use Standard > Print Preview to preview a design 
printout.

Embroidery 
information

Start/End
Crosshairs
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a scale factor. For example, if you print at 50%, 
you need to double the measurements on the 
worksheet when transferring to the fabric. Use the 
table below as a guide.

To print a design layout
1 Click the Print Preview icon.

Your design layout displays as it will be printed. See 
also Creating ornamental layouts.

2 Click Options.
The Print Options dialog opens.

3 Select Template Mode.
These settings show the design outline with no 
stitches.

Note  While the cloth setting marking is supported in 
JEF and SEW files, outlines are not. Since JEF and 
SEW are stitch file formats, they only contain stitch 

data, no outlines. The workaround is to display JEF and 
SEW files with stitches and cloth setter marking turned 
on.

4 Make sure Cloth Setter Marking and Work Area 
options are checked.
The cloth setter marking indicates the hooping center. 
They are printed for each hooping in the design. 

5 Select the Actual Size option in the Size group.
6 Click OK.

Each hooping has a number printed near the cloth 
setter mark to indicate the hoop sequence. 

Try this!  You can print out an overview of the layout by 
selecting Fit to Page or entering a value in the 
% of Actual field.

Printing color layers

The Color Layers option lets you include a list of 
color layers in the current design, together with 
color and stitch information for each layer.

To print color layers
1 Click the Print Preview icon.

Your design displays as it will be printed.
2 Click Options button.

The Print Options dialog opens.

% Scale Factor
50% 2:1 x 2
25% 4:1 x 4
20% 5:1 x 5
10% 10:1 x 10

Select Template
mode

Use Standard > Print Preview to preview a design 
printout.
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3 In the Other Worksheets group, select the Color 
Layers checkbox and click OK.

4 Click the Next Page button, as required.
A list of color layers is displayed together with color and 
stitch information for each layer.

The following information is included:

5 Click Print.

Printing appliqué patterns

Print a copy of the appliqué pattern to use as a 
template for cutting out fabric pieces. Each 
appliqué pattern piece is numbered according to 
the stitching sequence.

To print appliqué patterns
1 Click the Print Preview icon.

Your appliqué design displays as it will be printed.
2 Click Options button.

The Print Options dialog opens.

3 In the Other Worksheets group, select the Appliqué 
Patterns checkbox and click OK.
Each appliqué pattern piece is numbered according to 
the stitching sequence.

Note  If the Actual Size option is selected, both an 
assembled appliqué layout and individual patterns in 
the actual size are created on separate pages. If the 
Fit to Page or % of Actual options are selected, the 
assembled appliqué layout is created in the selected 
size, but individual patterns are still printed in the actual 
size on separate pages.

4 Click Print.

Printing multi-hooped designs

If there is more than one hooping in the design, 
you have the option of printing hoops in 
multi-hooping view in their correct color sequence. 
The Hooping List option shows the objects in 
each hooping. See also Hooping large designs.

Item Description
Number Number in the stitching sequence.
Color Color name listed in the associated 

thread chart.
Code Thread code for ease of ordering.
Brand Thread brand – e.g. Isacord 40.
Stitches Total stitch count for individual color 

layer.
Thread Used Total stitch length of the individual color 

layer in the measurement unit currently 
set for the system – e.g. ‘meters’.

Use Standard > Print Preview to preview a design 
printout.

Check to print
color layers

Check to print
appliqué patterns
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To print a multi-hooped design
1 Select File > Print Preview.
2 Click Options icon.

The Print Options dialog opens.
3 Select the Hooping List checkbox.

4 Click OK.
The following information is included showing the 
objects in each hooping.

5 Click Print.

Try this!  It is a good idea to include alignment marks 
with multi-hooped designs. These can be activated via 
the Work Environment < Combine tab. See 
Outputting alignment marks for details.

Check to print a
hooping list

Alignment marks included
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Chapter 12

Reading & Writing Design
Files

You can output embroidery designs in a variety of ways – saving to computer, 
USB memory stick, ATA PC card, or sending directly to machine for stitching.

Digitizer EXjr uses three native embroidery file formats – JAN, JEF and SEW – 
which allow you to make the most of both outline and stitch formats. JAN 
format is an object-based format while JEF and SEW formats are stitch-based. 
By default, Digitizer EXjr saves to JAN format. These formats contain all 
information necessary both for stitching a design and for later modification. 
When opening designs created or saved in other formats, Digitizer EXjr 
converts the design internally to JAN format. You can then modify it using the 
full range of Digitizer EXjr features. See also Supported embroidery file 
formats.
This section describes embroidery stitch and outline design formats, as well as 
how to open embroidery files in Digitizer EXjr. It also describes saving designs 
for machine as well as sending and receiving designs by direct connection. 
Writing designs to an external media drive is also covered.
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Embroidery design formats

Embroidery designs are saved in one of two 
formats – ‘outline’ format or ‘stitch’ format. JAN is 
an outline format while JEF and SEW are stitch 
formats.

Note  For details of specific formats supported by 
Digitizer EXjr, see Supported embroidery file 
formats.

Outline files
Outline files such as JAN are high-level formats 
which contain object outlines, object details and 
stitch data. They can be scaled and transformed 
without affecting stitch density or quality. After 
modification in Digitizer EXjr, you can save your 
design to the native JAN format, or to a different 
format altogether.

Stitch files
Different embroidery machines speak different 
languages. Before you can stitch a design, it must 
be in a format which can be interpreted by the 
machine. Stitch files such as JEF and SEW are 
low-level formats for direct use by embroidery 
machines. In their raw form, they are not suited to 
modification because stitches are not regenerated. 
However, Digitizer EXjr by default converts stitch 
files to outlines and objects upon opening. They 
can then be saved in JAN format. Processing is 
effective for most stitch designs but cannot 
produce the same level of quality as original 
outlines and may not handle some fancy stitches.

File sources
While embroidery files are broadly classified as 
‘outline’ or ‘stitch’, Digitizer EXjr internally tags 
files as belonging to one of four types – Native 
Design, Imported Outlines, Processed 
Stitches, or Imported Stitches.

Saving designs for machine

Different embroidery machines understand 
different languages. Each has its own control 
commands for the various machine functions. 
Before you can stitch a design, it must be in a 
format which can be interpreted by the machine. 
Before design files are sent to machine, they are 
automatically converted to JEF stitch file format. 
They can also be saved directly to hard disk. When 
saving in JEF format, you must choose the 
particular machine type you wish to save for. See 
also Sending & writing designs. 

To save a design for machine
1 Select File > Save As.

The Save As dialog opens.

2 Select the folder where you want to save the design 
from the Save In list.

3 Enter a name for the design in the File name field.
4 Select JEF as the file format from the Save as type list.
5 Select the required machine type and click OK.

Source Description
Native 
Design

Designs created in Digitizer EXjr (or 
equivalent).

Imported 
Outlines

Designs read from non-JAN outline files 
where stitches have been generated in 
Digitizer EXjr (or equivalent) from original 
outlines and stitching data.

Processed 
Stitches

Designs read from stitch files where stitches 
have been regenerated by processing.

Imported 
Stitches

Designs read from stitch files, where 
outlines may or may not have been 
recognized, but stitches have not been 
regenerated through stitch processing.
Note, however, that if you change a stitch 
design – e.g. add a lettering object – the 
status changes to ‘Processed Stitches’ even 
though the imported stitches may not have 
been regenerated.

Source Description

Select JEF format

Select Save location
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6 Click Save.

Note  Digitizer EXjr supports Wilcom MA and Giga 
hoops. These are two-position hoops which expand the 
available sewing area. When sending to machine, in 
most cases Digitizer EXjr will only create one file as the 
two hoop positions are saved in a single JEF file. 

With Giga hoop designs, the red area is stitched first, 
the hoop is rotated, and then the blue area is 
stitched. If, in the design sequence, the blue area is 
stitched before the red area, it cannot be saved as a 
Giga hoop design. See also Sending designs with a 
Giga Hoop.
If the design will not stitch as a single Giga hoop 
design – i.e. it would require more than one rotation 
of the Giga hoop in order to preserve the stitching 
sequence – the following message is displayed:

In this case, you need to use Combine mode to 
create two Hoop B hoopings as instructed. See 
Hooping large designs for details.

Sending & writing designs

Digitizer EXjr supports various sets of machine 
model. Some Elna machines can be connected by 
cable directly to your PC via the USB port. 
Older-style machines do not support direct 
connection but they do read ATA PC cards and/or 
USB memory sticks.

Note  Before design files are sent to machine, they 
are automatically converted to JEF stitch file 
format. See also Saving designs for machine.

Direct connection
Digitizer EXjr is able to automatically detect which 
type of supported machine is currently connected 
to the PC USB port. The Machine menu items are 
determined by the type of machine connected to 
the PC. If no machine is detected, all menu items 
will be grayed out. Your distributor will advise you 
about supported machine types. See also 
Supported machine models.

Note  Before design files are sent to machine, they 
are automatically converted to JEF or JPX stitch file 
format. See also Saving designs for machine.

Supported storage devices
Besides USB connection, you can write to an 
external media drive in a similar way as you would 
save to floppy disk. The ATA PC card is a PCMCIA 
standard PC memory card that is used for storing 
designs in JEF format to be read/written from/to 
machine. The ATA PC card is designated as a drive 
in your computer. The drive designation may 
become E: or F: or some other letter. After writing 
your design, you simply insert the card into the 
ATA PC card slot of your machine (if supported), 
and read the design.

USB memory sticks
The latest machine models can read from and write 
to USB memory sticks. These are very convenient 
portable memory devices which can hold large 
amounts of data in a small ‘stick’.

ATA PC cards
It is recommended to save data stored in the 
machine’s built-in memory to hard disk or 
ATA PC card to prevent accidental loss of data 
due to improper operations or malfunctions.
If an ATA PC card is formatted on PC or on your 
machine, all information on the card will be lost. 
Check the contents of any used cards before 
formatting them.
Only use approved ATA PC cards or SanDisk 
CompactFlash with ATA PC card adapter for 
updating the system program of your 
embroidery machine. Memory capacity should 
be 8Mb or more.

Note  If your computer is a laptop, there is a slot 
where you can insert the ATA PC card and its 
adapter directly. If you have a desktop computer, 
you will need an ATA PC card reader/writer 
connected to a USB port.

Sending designs to machine

Use Standard > Send to Machine to send a design 
to a machine for stitching.
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Depending on the machine model, the direct 
machine connection option may be available to 
you. This means you can send individual or 
multiple design files directly to three possible 
destinations:

Built-in: internal machine memory
ATA PC Card: PC memory card slot on machine 
which can be used as an ATA PC card 
reader/writer
USB Memory: USB stick attached to your 
machine.

Try this!  Alternatively, you can use an external 
media drive to write designs in JEF format directly 
to card. See Writing to external media for details.

Sending the current design to machine
The procedure for sending a single design to 
machine varies slightly with the machine model, 
but the principle is the same. Whichever machine 
you are using, the steps will involve one or all of 
the following:

Insert the ATA PC card or USB stick into your 
machine as required.
Open or create the design you want to send.
Click the Send to Machine icon or select Machine 
> Send Current Design.
The particular dialog which opens will depend on 
the selected machine model.

Select a storage location on the sewing machine 
– machine memory (built-in folder), ATA PC 
card, or USB memory stick.
Start the file transfer.
In the unlikely event that a file exceeds the 
limits set, it will be split into two or more files.

Note  For detailed procedures relating to your 
particular machine, refer to your machine 
documentation.

Sending or receiving multiple designs
As with single designs, the procedure for sending 
multiple designs to machine varies slightly with the 
machine model you are using.

In addition to sending design files to machine, you 
can generally receive or delete files from the 
destination folder.

Note  For detailed procedures relating to your 
particular machine, refer to your machine 
documentation.

Click to send
design to machine

Click to change
name of output file

Select destination
folder on sewing

machine

Select files to
send

Use buttons to
navigate folders of

display file list

Select source
folder on your PC

Select files to 
receive or delete

Receive or
delete files

from machine
location
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Writing to external media

You can use an external media drive to write 
designs in JEF format directly to a drive. Some 
machines do not support direct connection, in 
which case you will need to use this method to 
transfer design files to machine. Depending on the 
machine model the card is intended for, make sure 
this is selected as your current machine. After 
writing your design, simply attach the external 
media to your machine and read it.

Writing a design to ATA PC card
The procedure for writing a single design to card 
varies slightly with the machine model, but the 
principle is the same. Whichever machine you are 
using, the steps will involve one or all of the 
following:

Select the machine model you intend to write to. 
See Selecting machine models for details.
Make sure the reader/writer is securely plugged 
into the USB port of your PC.
Open or create the design you want to send.
Click the Write to External Media icon or select 
External Media > Write a Design.
The particular dialog which opens will depend on 
the selected machine model.

Start the file transfer.
In the unlikely event that a file exceeds the 
limits set, it will be split into two or more files.

Note  For detailed procedures relating to your 
particular machine, see Outputting to Machine.

Note  For detailed procedures relating to your 
particular machine, refer to your machine 
documentation.

Writing multiple designs to ATA PC card
As with single designs, the procedure for writing 
multiple designs to ATA PC card varies slightly with 
the machine model. Select the machine model you 
intend to write to and select External Media > Write 
Designs, Read and Erase. The particular dialog 
which opens will depend on the selected machine 
model. See Selecting machine models for details.

In addition to writing design files to machine, you 
can generally receive or delete files from the 
destination folder.

Use Standard > Write to External Media to send a 
design to an external media drive. 

Click to
change name

of output file

Click to write
design to card

Select files to
write

Use buttons to
navigate folders of

display file list

Select source
folder on your PC

Click to read Click to erase
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Note  For detailed procedures relating to your 
particular machine, refer to your machine 
documentation.

Sending designs with 
multi-position hoops

Digitizer EXjr supports both MA and Giga hoops. 
These are two-position hoops which expands the 
available sewing area of the machine for which it is 
supplied.

Sending designs with an MA Hoop 

Digitizer EXjr supports the MA Hoop. This is a 
two-position hoop which expands the available 
sewing area of the machine for which it is supplied. 
In the list of available hoops, the MA Hoop is 
identified as ‘Hoop MA (200 x 280)’. The two 
sewing fields are shown in red and blue. When 
digitizing, each embroidery object must fit entirely 
into one or other hoop position.
The behavior of the MA Hoop during loading and 
editing of embroidery designs is exactly the same 
as for a normal rectangular hoop of size 200 x 280. 
The fact that there are two sewing fields has no 
effect until you save the design or send it to a 
machine. When sending to machine, in most cases 
Digitizer EXjr will only create one file as the two 
hoop positions are saved in a single JEF file. 
However, if a return to hoop position 1 is required, 
Digitizer EXjr will create two (or on rare occasions, 
more) files.

To send a design with an MA Hoop 
1 Open the design to send to machine.

The two sewing fields are shown in red and blue. When 
digitizing, each embroidery object must fit entirely into 
one or other hoop position.

Note  Sizes are shown in mm for a 1:1 display. At other 
display scales, values are scaled proportionally.

2 Click the Send to Machine icon on the Standard 
toolbar or select Machine > Send Current Design.
If the machine is correctly linked, the Send Current 
Design dialog opens. See Sending & writing designs 
for details. 

3 Click the Send button.
Digitizer EXjr determines whether there are any 
objects that do not lie wholly within one of the hoop’s 
two positions:

If there are, they are selected in the design window 
and you are prompted to edit or delete them. 
Otherwise Digitizer EXjr determines how many 
hoopings are needed.
If only one is needed, or two with the upper position 
first, Digitizer EXjr creates a single JEF file 
containing these hoopings and sends it to the 
machine. 
Otherwise it calculates the number of hooping 
position changes and prompts you to proceed. If you 
agree, it creates multiple JEF files and sends them to 
machine.

4 Click OK.
The JEF file names are numbered with a hyphen – ‘My 
Flower- 1.JEF’ and ‘My Flower- 2.JEF’.

Note  When the machine loads the first of the multiple 
JEF files, it stitches the upper-position first, then 
prompts you to move the hoop to the lower position. 
Always have the hoop in the upper position when the 

Use Standard > Send to Machine to send the 
current design directly to machine for stitching.

Upper position

Lower position

MA Hoop
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machine starts stitching a new JEF file unless you are 
explicitly prompted to shift frame. This may be 
necessary in cases where a hooping pair must be split 
because it has too many stitches or too many color 
changes.

Sending designs with a Giga Hoop

Digitizer EXjr supports the Giga Hoop. This is a 
two-position hoop which expands the available 
sewing area of the machine for which it is supplied. 
In the list of available hoops, the Giga Hoop is 
identified as ‘Hoop D (220 x 190) (Giga)’. The two 
sewing fields are shown in red and blue. The red 
area is normally stitched first then, after rotating 
the hoop, the blue area is stitched. When 
digitizing, each embroidery object must fit entirely 
in one or other hoop position. If the design in the 
blue area is sequenced before the red area, you 
cannot save the design as a Giga hoop design.

Note  The original embroidery area of the Giga 
Hoop is 230 x 200 mm, however when the hoop is 
rotated, it may cause a small positioning gap. To 
avoid this problem a margin of 5mm is put inside 
the hoop which makes the actual embroidery area 
220 x 190 mm.

To send a design with a Giga Hoop 
1 Open the design to send to machine. The two sewing 

fields are shown in red and blue. When digitizing, each 
embroidery object must fit entirely into one or other 
hoop position.

2 Click the Send to Machine icon on the Standard 
toolbar or select Machine > Send Current Design. If 
the machine is correctly linked, the Send Current 
Design dialog opens. See Sending & writing designs 
for details. 

3 Click the Send button.
Digitizer EXjr determines whether there are any 
objects that do not lie wholly within one of the hoop’s 
two positions.

If the design can be stitched in the Giga hoop, the 
Send a Design (on-line) dialog opens.
If the design will not stitch as a single Giga hoop 
design – i.e. it would require more than one rotation 
of the Giga hoop to preserve the stitching sequence 
– the following message is displayed:

Click OK and use Combine mode to create two 
Hoop B hoopings as instructed. See also Combining 
& Sequencing Objects.

4 Select the design name and click the Send button.

Note  The design will be sent to the machine as two 
individual JEF files – Hoop position A and Hoop 
position B. However, the machine display will show the 
design as a single design unless the file cannot be 
stitched in two files due to the object stitching 
sequence.

Outputting multi-hooped designs

When working with designs that are larger than the 
available physical hoop, you can split them into 
parts in Combine mode, each containing an object 
or group of objects. When a multi-hooped design is 
output, each part is stitched separately after the 
fabric has been re-hooped. See Hooping large 
designs for details.

Use Standard > Send to Machine to send the 
current design to a machine for stitching.



Digitizer EXjr Instruction Book
Chapter 12 Reading & Writing Design Files

95

The following commands are all available in 
Combine mode:

Save As
Send to Machine
Write to External Media

When any of these commands is invoked, 
multi-hoopings and split lines are applied. 
Hooping Sequence mode is activated, showing 
the separate hoopings. See also Printing 
multi-hooped designs.

Hoopings vs output files
It is important to realize the numbers of hoopings 
in a multi-hooped design do not necessarily 
correspond to the number of output files. It all 
depends on the layering of objects within the 
design. In order to preserve the digitized stitching 
sequence, the same hooping may need to be 
visited more than once.

Take the simple scenario illustrated above. Here we 
have one design with three objects and two 
hoopings. Object #1 gets stitched first. But then a 
change of hooping is required to stitch Object #2. 
To stitch Object #3, we need to return to our first 
hooping. That’s how we come to have more output 
files than we have hoopings.

Sending multi-hooped designs to 
machine

With a multi-hooped design, you can send one or 
more stitch files to sewing machine or memory 
card. The software automatically calculates which 
files are to be sent and shows you how they will 
look.

To send a multi-hooped design to machine
1 Switch to Combine mode and create your 

multi-hooped design. See Hooping large designs for 
details.

2 Ensure that the embroidery machine or reader box 
have been correctly attached.

3 Click the Send to Machine icon.
The system checks whether there is more than one 
hoop in the design and if all objects are covered.

Hooping 1 Hooping 2

1 2

3

Use Combine > Combine Mode to activate the 
combined hooping functions.

Use Standard > Send to Machine to send the 
current design directly to machine for stitching.
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If some objects are uncovered, you are prompted to 
continue or otherwise.

All hoopings needed to stitch the design are 
displayed in Hooping Sequence mode.
All toolbars are hidden, leaving only the Hooping 
Sequence panel. This displays a list of all hoopings 
required to stitch the design.

Note  Fabric in covered appliqués is hidden, leaving 
stitchable items only. 

4 Select any hooping in the list.
Objects within the selected hooping are shown in their 
actual stitch colors. Objects not included in the 
selection are shown as grey outlines.

5 Use the zoom controls at the top to inspect the 
hoopings.

6 Click the Send Selected Now button to send the 
selected hooping to machine.
The system outputs a file containing everything to be 
stitched within the current hooping.

Note  Depending on your selected machine, you may 
have the option to ‘send all now’. With this option, the 
individual hoopings are controlled by the machine 
connection software. See Outputting to Machine for 
details.

7 Repeat this process as many times as necessary to 
send all hoopings.

8 Click Close to end.

Saving multi-hooped designs

If more than one hooping is needed to cover your 
design, you may split it into separate files for each. 
See Hooping large designs for details.

List of hoopings in 
current design 
displayed in Hooping 
Sequence panel

Selected hooping 
shown in actual 
stitch colors

Objects not included 
in selection shown as 
grey outlines

Send selected
hooping to

machine

Use Combine > Combine Mode to activate the 
combined hooping functions.

Use Standard > Save to save the current design.

Use Standard > Write to External Media to send a 
design to an external media drive. 
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To save a multi-hooped design
1 Switch to Combine mode and create your 

multi-hooped design. See Hooping large designs for 
details.

2 Select File > Save As.
A standard MS Windows® Save As dialog appears 
allowing you to browse to any folder, choose any name 
for the exported file, and choose a file format from a 
dropdown list.

Note  Alternatively, use the Write to External Media 
command to save output files to memory card. See 
Writing to external media for details.

3 Change the file name as required, and choose a 
destination folder and/or file format, and click Save.
The system checks that all embroidery objects are 
covered. You will be warned if they are not. Otherwise, 
all hoopings needed to stitch the design are calculated 
and displayed in the Hooping Sequence dialog. 
Hoopings are named as files with the chosen file 
extension.

Hoopings named as 
files with chosen file 
extension

Save all or
selected hoopings

to machine
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4 Select a hooping and click Save Selected Now.
Alternatively, click Save All Now to save all files in the 
list, named as indicated in the Hooping Sequence 
panel. Digitizer EXjr outputs the hoopings to their 
individual files.

5 Click Close.
Digitizer EXjr exits Hooping Sequence mode and 
displays the design in the design window in its original 
state.
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Appendix A

Quick Reference

Digitizer EXjr uses toolbars and shortcut keys to provide quick and easy access 
to common commands. This section provides a list of all keyboard shortcuts 
available in the software, as well as short descriptions of the tools you will find 
in the toolbars. 

Digitizer EXjr Design Window Digitizer EXjr can be launched from your Windows 
desktop or program group under the Start menu. 
Once started, you can open existing JAN files or 
create new files from scratch. The screen image 
below displays an exploded view of all toolbars in 
the Digitizer EXjr Design Window.

Double-click to start Digitizer EXjr.

Menu bar

Standard toolbar

Title bar

Status bar

Design Window

View toolbar

Lettering toolbar

Digitize toolbar

Edit toolbar

Easy Layout toolbar

Docker toolbar

Prompt line

Combine toolbar

Color Palette
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Tools and toolbars

You can access commands using the toolbar 
buttons on the toolbars on your design window. To 
use a tool, simply move the mouse pointer over it, 
and click with the left mouse button.

Standard toolbar

Digitize toolbar

Docker toolbar

Edit toolbar

Tool Description

Click New to start a new design with the NORMAL 
template.

 

Use Open to open an existing design.

 

Use Save to save the current design.

 

Use Print to print a design using the current 
settings.

 

Click Print Preview to preview the design printout 
on screen.

Click Cut to cut selected objects to the clipboard.

Click Copy to copy selected objects to the 
clipboard.

 

Click Paste to paste copied objects in the design.

The software supports various sets of 
machine model. Some machines can be 
connected by cable directly to your PC via 
the USB port. 

Use Send to Machine to send a design to a 
machine for stitching.

Use Send to EmbLink to send the current design 
to the external HorizonLink application.

Use Write to External Media to send a design to 
an external media drive. 

Use Undo to undo a command.

Use Redo to reapply a command which has been 
‘undone’.

 

Click Stop to cancel the function you are using or 
cancel all selections in a design.

Tool Description
Use Click-to-Design to create embroidery 
designs directly from imported images using 
default settings.

 

Use Image Preparation to reduce the number of 
colors and remove image ‘noise’ in non-outlined 
images.
Use Click-to-Parallel Weave Fill to digitize large 
artwork shapes with Parallel Weave Fill, 
preserving any holes within.
Use Click-to-Parallel Weave Fill without Holes to 
digitize large artwork shapes with Parallel Weave 
Fill, ignoring any holes within.

Use Click-to-Centerline to digitize centerlines in 
artwork with run line stitches.

Use Match to Palette to find the nearest match 
between a selected image color and thread color. 
If not selected, the color is digitized in the current 
palette color.

Tool Description

Use Resequence to resequence selected objects 
by color.

 

Click Color Palette to open the Color Palette. Use 
this to change colors of selected objects or set 
default color for new objects.

Tool Description
Click Select and click an object to select it. 
Alternatively, drag a bounding box around the 
object to select.
Use Object Details to set details for selected 
objects or the current design as a whole.

Click Flip Vertically to flip a selected object or 
design up/down.

Click Flip Horizontally to flip a selected object or 
design left/right.

Click Rotate 45° CCW/CW to rotate a selected 
object or design by 45° clockwise. Right-click to 
rotate by 45° counter-clockwise.
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Easy Layout toolbar

Combine toolbar

Lettering toolbar

View toolbar

Keyboard shortcuts

General functions

Tool Description

Use Display Layout Work Area to toggle display 
of the defined work area.

Use Define Layout Work Area to access the Easy 
Layout Work Area dialog.

Use Copy And Mirror To Corners to automatically 
create copies of any selected object/s in each 
corner of the layout work area.

Use Move To Center to automatically move 
selected object/s to the center of the work area.

Use Apply to generate the object/s and stitches of 
copies created by Easy Layout operations. 
Pressing the Enter key has the same effect.

Tool Description

Use Combine Mode to activate the Combine 
functions.

Use Add Hoop to center a new hoop in the design 
window in an upright orientation.

Use Delete Hoop to remove selected hoops from 
the design window.

Use Calculate Hoopings to evaluate the hoopings 
that will result from the current hoop layout.

Click Rotate Hoop with left or right mouse buttons 
to rotate a selected hoop 90° in either direction.

Tool Description

Click Monogramming to add monograms directly 
on-screen.

Use Lettering to add embroidery lettering to 
designs or edit selected lettering.

Use Font List to change font of 
selected lettering. 

Use Font Size setting to adjust size (in mm 
or inch) of selected lettering objects.
Use Font Width setting to adjust size (in %) 
of selected lettering objects.

Use Italics Slant Angle setting to change 
the angle of selected lettering. 
Use Orientation droplist to change 
orientation of selected lettering.

Tool Description

Click Zoom In to display a design at twice its 
current size.

Click Zoom Out to display a design at half its 
current size.

Click Zoom Factor to zoom in on a section of a 
design.

 

Click Visualizer to change between normal view 
and Visualizer view.

Use Display Images to show and hide backdrops.

Click Display Vectors to toggle on/off display of 
vector graphics in Embroidery mode.

Click Display Grid to hide or show the grid.

Click Display Rulers and Guides to toggle on 
rulers and guides. 

Click Display Hoop to hide or show the hoop.

Use Design Measurement System to change 
the measurement system used by the software.

Use Slow Redraw to view the stitching and color 
sequence of a design in slow motion.

To Press
Create a new design C+N

Open an existing design C+O

Save a design C+S

Print a design C+P

Tool Description
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Selection functions

Viewing functions

Editing functions

Travel functions

Exit an application A+4

Show/hide Color Palette C+R

Open Thread Colors A+T

Open Object Details A 

Set work area C+w

Show/hide Resequence List V+L

Apply/select Satin V+I

Apply/select Weave V+M

Apply/select Run V+N then 
press j

To Press or Click
Choose Select tool O

Select multiple objects C+[ 
Select a range of objects V+[

First and last 
objects

Select next object T 
Select previous object V+T 
Add next object to selection C+T 
Add previous object to selection C+V+T

Select all objects C+A 
Deselect all objects E or X 

To Press
Show/hide images D

Measure a distance on screen M

Show/hide hoop V+H

Show/hide whole hoop /

Show/hide whole design 0 (zero)
Show/hide stitches S

Show/hide needle points . (period)
Show/hide connectors V+C

Show/hide grid V+G

Show/hide work area W

Redraw the screen R or 4
Redraw slowly V+r

Turn on/off Visualizer T

To Press

To Press or click
Cut an object C+X 

Copy an object C+C 
Paste an object C+V 
Duplicate an object C+D 
Delete selected objects or last object D 
Group selected objects C+G

Ungroup selected objects C+U 
Lock selected objects K

Unlock selected objects V+K

Nudge selected object [+t b l r 
Undo a command C+Z 
Redo a command C+Y

Cancel command E 

To travel Keyb’rd † Keypad ‡

To start of design h 7 
To end of design e 1 
To next color d 3 
To previous color u 9 

† Press Esc first ‡ Num Lock OFF 
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Supported Files & Hoops

Details are provided here of the embroidery file types, and vector and bitmap 
formats supported by Digitizer EXjr as well as supported hoop types.

Supported embroidery file formats

There are two types of embroidery file formats:
Outline files: Outline or ‘condensed’ files 
usually contain digitized shapes and lines, 
selected stitch types and stitch values and 
effects.
Stitch files: Stitch files contain only stitches 
and machine functions and are suited to specific 
embroidery machines.

See also Reading & Writing Design Files.
The following file formats are supported by 
Digitizer EXjr:

JPX file format
The JPX production file format includes a JPG 
image, in addition to the embroidery, of any 
graphics included in the design. This provides you 
with a better means of visually aligning embroidery 
on a printed item when hooped in the machine.
Older machines display only thread codes and not 
the specific brand. This causes confusion as the 
same code across two (or more) different brands of 
thread may be completely different colors. With 
the newer Elna machines, a thread brand ID 
identifying the thread chart is now recognized by 
the machine. The specific thread brand is now 
displayed on the machine itself. A brand 
designation for the thread chart is written to the 
JPX file so the machine knows which brand of 
thread the design is using.

Extension Format Read Write
JAN JANOME Design
JAN Digitizer Jr./Pro/MB V3.0
JAN DigitizerPro V1.0/V2.0
JAN Digitizer 10000 V2.0
JPX JANOME/Elna/Kenmore
JEF JANOME/Elna/Kenmore
JEF+ JANOME/Elna/Kenmore
JMT JANOME template
SEW JANOME/Elna/Kenmore
EMX Janome Cross Stitch
CSD POEM/Singer/Huskygram 

EU
DST Tajima
EMD Elna

† Digitizer EX only

EXP Melco
HUS Husqvarna/Viking
PCM Pfaff
PCS Pfaff
PEC Deco, Brother, Babylock
PES Deco, Brother, Babylock
VIP Husqvarna/Viking/Pfaff
VP3 Husqvarna/Viking/Pfaff
XXX Singer
DSB Barudan †
U?? Barudan †
10O Toyota †

Extension Format Read Write

† Digitizer EX only
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Supported electronic artwork 
formats

Artwork can be imported into Digitizer EXjr in both 
vector and bitmap formats. Generally speaking, 
vector images preserve the picture quality when 
resized, whereas bitmap images cause problems of 
pixilation and image degradation when enlarged or 
scaled down. However, any scaling required should 
be done before importing into Digitizer EXjr as the 
importing operation automatically transforms 
vector images into bitmaps. See Digitizing with 
Artwork for details.

Supported vector formats (Embroidery 
mode)
Digitizer EXjr Embroidery mode supports the 
following vector formats:

Supported bitmap formats (Embroidery 
mode)
Embroidery mode also supports the following 
bitmap formats:

Supported hoop types

Digitizer EXjr supports a variety of hoop types 
used with the different machine models. See also 
Selecting machine models.

The Hoop List is automatically filtered according 
to current machine type. Only those hoops 
supported by the current machine are available. 
See Grids & Hoops for details.

Note  If you attempt to save a design in a hoop size 
not supported by the machine, Digitizer EXjr will 
prompt you to select a different hoop. If you 
attempt to send a design to machine with a hoop 
not supported by the machine, you will be 
prompted to select a different hoop. See also 
Saving designs for machine.

Extension Format Read Write
EMF Enhanced Metafile
EPS Encapsulated PostScript
WMF Windows Metafile

Extension Format Read Write
BMP Windows Bitmap
JPG JPEG File Interchange
PCX ZSoft
PNG Portable Network Graphics

Hoop Type
Machine Model

eXp. 860  eXp. 900

Hoop SQ14a (140 x 140)

Hoop RE20a (170 x 200)

Hoop FA10a (100 x 40)

Hoop SQ14 (140 x 140)

Hoop SQ23 (230 x 230)

Hoop GR (230 x 300)

Hoop FA10 (100 x 40)

Hoop ASQ22 (220 x 220)

Hoop HH10 (100 x 90)
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Packaged Fonts

The table below includes all fonts that are standard with your Digitizer EXjr 
software. For best results when stitching, do not exceed the recommended 
maximum or minimum sizes. Recommended maximum and minimum 
heights refer to UPPER CASE letters. Some lower case letters – e.g. a and c 
– are about 70% the height of a capital letter. Thus you may need to make 
these characters larger than the recommended minimum.
You can create special characters in each font by holding down the Alt key 
on your keyboard and typing 0 (zero), its code, using the numbers on the 
keypad. For example, to type ê with the code 234, type Alt+0234. The 
accented letter will appear when you release the Alt key. Note that not all 
characters are available in all fonts. See also Adding special characters.

Standard fonts

Font Sample
 Recommended Sizes

Min Max
in. mm in. mm

Art Block 0.4 10 3.0 75

Bauhaus 0.4 10 2.0 50

Block1 0.27 7 1.8 45
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Brush 0.32 8 2.0 50

First Grade 0.5 12 1.15 30

Galant 0.5 13 2.0 50

Hollowblock 0.4 10 2.4 60

Jupiter 0.25 6 1.2 30

Lazer 0.24 6 2.0 50

Old English 0.3 8 2.0 50

Poetic Script 0.6 15 3.1 80

Run Freehand 0.2 5 0.5 12

Font Sample
 Recommended Sizes

Min Max
in. mm in. mm
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Script 1 0.5 13 3.0 75

Typist 0.5 13 2.0 50

Western 0.4 10 1.4 35

Font Sample
 Recommended Sizes

Min Max
in. mm in. mm
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Monogramming fonts

Digitizer EXjr contains four legacy Monogram Alphabets – Fancy Monogram, 
Octagon Monogram, Point Monogram and Seal Monogram. Monogram 
alphabets provide three sets of the upper-case alpha characters. The first, 
known as the ‘left set’, is designed to appear on the left side of a monogram. 
The second, or ‘middle set’, is designed for the middle position(s) of a 
monogram. The ‘right set’ is designed to appear on the right side of a 
monogram. Each set is mapped to a specific set of character equivalents in 
the alphabet.

Letter A B C D E F G H I J K L M

Left ! “ # $ % & ‘ ( ) * + , -

Middle A B C D E F G H I J K L M

Right a b c d e f g h i j k l m

Letter N O P Q R S T U V W X Y Z

Left . / 0 1 2 3 4 5 6 7 8 9 :

Middle N O P Q R S T U V W X Y Z

Right n o p q r s t u v w x y z
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Fancy Monogram
Fancy Monogram is a special monogramming alphabet using three sets of 
the upper-case alpha characters.

Alphabet contains
Left, Center and Right letters for 3-letter monogram. Use 
symbols for the left letter, upper case for the center letter, and 
lower case for the right letter.

Colors 1 color

Stitching Satin

Recommended height
Minimum 1.0 in 25 mm

Maximum 4.0 in 100 mm
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Octagon Monogram
Octagon Monogram is a special monogramming alphabet using three sets of 
the upper-case alpha characters.

Alphabet contains
Left, Center and Right letters for 3-letter monogram. Use 
symbols for the left letter, upper case for the center letter, 
and lower case for the right letter.

Colors 1 color

Stitching Satin

Recommended height
Minimum 0.7 in 18 mm

Maximum 4.0 in 100 mm
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Point Monogram
Point Monogram is a special monogramming alphabet using three sets of the 
upper-case alpha characters.

Alphabet contains
Left, Center and Right letters for 3-letter monogram. Use 
symbols for the left letter, upper case for the center letter, 
and lower case for the right letter.

Colors 1 color

Stitching Satin

Recommended height
Minimum 0.7 in 18 mm

Maximum 4.0 in 100 mm
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Seal Monogram
Seal Monogram is a special monogramming alphabet using three sets of the 
upper-case alpha characters.

Alphabet contains
Left, Center and Right letters for 3-letter monogram. Use 
symbols for the left letter, upper case for the center letter, 
and lower case for the right letter.

Colors 1 color

Stitching Satin

Recommended height
Minimum 0.7 in 18 mm

Maximum 4.0 in 100 mm
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Index

A
Add Hoop tool 24, 102
alignment marks, outputting 25
anchor points, rotation 61
anti-aliasing 35
appliqué

printing 84, 86
arranging objects 58

grouping 59
locking 59

artwork
anti-aliased images 35
choosing 34
dithered images 35
scanning 35

ATA PC cards 4, 90
Auto Color Reduction dialog 37
Auto Scroll 19
automatic

backup 19
digitizing 37, 39
save options 19

B
backdrops

digitizing with backdrops 34
displaying 31
locking and unlocking 59
using bitmap images 36

backgrounds
changing colors 16
changing fabrics 16
color mixing 17

bitmap images
anti-aliasing 35
dithered 35
supported formats 105
using as backdrops 36

borders

digitizing 47
setting width 47

bounding box
selecting objects 43

C
Calculate Hoopings tool 24, 102
calibrating monitor 7
characters, special 69
Choose Fabric dialog 15
circular orientations 70
Click-to-Centerline tool 37, 39, 101
Click-to-Design tool 39, 101
Click-to-Parallel Weave Fill tool 37, 

38, 101
Click-to-Parallel Weave Fill without 

Holes tool 37, 38, 101
cloning, objects 55
Cloth Setter device 82
color layers, printing 85
Color Palette tool 17, 45, 101
Color-Object List

displaying hidden objects 43
docker 43
selecting objects 43

colors
changing 45
changing background 16
mixing background 17
resequencing by 56
traveling by 30

Colors dialog 17
columns

digitizing 47
setting width 47

Combine Mode tool 24, 95, 96, 102
Combine toolbar

Add Hoop 24, 102
Calculate Hoopings 24, 102
Combine Mode 24, 95, 96, 102

Delete Hoop 24, 102
Rotate Hoop 24, 102
Rotate Hoop 90° CCW / CW 23

combining
designs 53
objects 53

commands
popup menus 11
selecting 11
undo/redo 11
using toolbars 11

condensed files 89
connections, peripheral device 

settings 3
consecutive objects, selecting 43
conversion tables

supported stitch file formats 104
Copy tool 54, 101
copying

cloning objects 55
duplicating objects 55
objects 54

Create Special Tools Flyout
Insert Offset Object 40

custom orientations 71
cut & paste objects 54
Cut tool 101

D
Delete Hoop tool 24, 102
deleting

objects 55
design information, viewing 32
Design Measurement System 

droplist 14, 102
design printouts 32

print options 82
printing 82, 90

designs
adding lettering 68
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combining 53
converting formats (tables) 104
creating new 10
measuring 14
opening 10
opening multiple 10
previewing 32
print preview 81
printing 81
redrawing slowly 30
saving 18
saving multi-hooped 96
sending and receiving 90
sending multiple to machine 91
sending single designs to 

machine 91
viewing 27
with MA Hoop 93
writing single designs to 

machine 91
dialogs

Auto Color Reduction 37
Choose Fabric 15
Colors 17
Guide Position 13
Monogramming > Lettering 73
Multiple Hoopings 97
Object Details > Dimensions 59, 

60
Object Details > Fill Stitch 47, 48, 

49, 50, 77
Object Details > Lettering 68, 70, 

78
Object Details > Parallel Fill 45
Object Not Covered 95, 97
Print Options 82–85
Print Preview 81
Resequence 56
Save As 19, 89
Save Options 89
Screen Calibration 7
Select by Color 27
Select Symbol 69
Slow Redraw 30
Thread Colors 18
Work Environment 22
Work Environment > Autosave 56
Work Environment > Autosave 

tab 19
Work Environment > Display 16, 

17, 21, 56
Work Environment > Edit 56
Work Environment > Scrolling 19

Digitize toolbar
Click-to-Centerline 37, 39, 101
Click-to-Design Instantly 39, 101
Click-to-Parallel Weave Fill 37, 38, 

101
Click-to-Parallel Weave Fill 

without Holes 37, 38, 101
Image Preparation 36, 101

Lettering 76
Match to Palette 37, 101

DigitizerJr
starting 100

digitizing
automatic 37
columns and borders 47
with backdrops 34

digitizing methods, Satin Line 47
Display

Display Rulers and Guides tool 13, 
21

Grid tool 12, 21, 102
Hoop tool 102
Images tool 31, 102
viewing selected parts 29

Display Hoop tool 12
Display Vectors tool 31, 102
distances, measuring 14
dithering 35
Docker toolbar

Color Palette 17, 45, 101
Resequence 43, 56

Duplicate command 55
duplicating objects 55
duplication options, setting 56

E
EasyDesign

starting 9
Edit menu

Duplicate 55
Lock 59
Unlock 59

Edit toolbar
Flip Horizontally 62, 101
Flip Vertically 62, 101
Object Details 101
Resequence 101
Rotate CCW/CW 61, 101
Select 42, 55, 78, 79, 101

effects, Travel on Edge 49
Embossed Fill

pattern size 50
stitch angle 51

embossed fills, creating 50
embroidery

design formats 89
elements, printing 83
file formats 104
files, opening 89
hoop 14
lettering 68
machine connections 3
machine, see also machine 

formats
Embroidery menu

Insert Design 53

F
fabrics, changing backgrounds 16
file types, outline & stitch files 104
files

combining designs 53
opening embroidery 89
stitch 89

fills
Embossed 50
Weave 48

fixed-length horizontal 
orientations, creating 70

Flip Horizontally tool 62, 101
Flip Vertically tool 62, 101
formats

design 89
embroidery file 89
expanded 89
outline 89
stitch 89

G
grid

hiding/showing 12
setting spacing 21

grouping objects 59
Guide Position dialog 13

H
hardware

peripheral device settings 3
setting up embroidery 

machines 3
hidden objects, display 43
hoop types, supported 105
hooped designs

outputting 94
sending to machine 95

hoops 21
centering 23
changing 22
displaying 12
embroidery 14
rotating 23
size, changing 22

horizontal orientations 70

I
Image menu

Insert Image 36
Image Preparation

tool 36, 101
images
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anti-aliased 35
bitmaps 36
digitizing automatically 37, 39
dithering 35
non-outlined 36
scanning 35, 39

Imported Outlines files 89
Imported Stitches files 89
initials, monogram lettering 72
Insert Design command 53
Insert Image command 36

J
JAN format 89
JEF format 89

L
layout, adjusting lettering 75
length, Run 46
lettering

adding 68
adjusting layout 75
changing stitch types 77
editing 76
entering on-screen 68
scaling 77–79
selecting symbols 69
setting orientation 69
special characters 69
transforming 79

lettering orientation, selecting 69
Lettering tool 68–76, 102
Lettering toolbar

Lettering 68, 69, 102
Monogramming 72–73, 102

Lock command 59
locking

backdrops 59
objects 59

M
MA Hoop, sending designs 93
machine

formats, saving 89
models, selecting 12
sending multi-hooped designs 95
sending single designs 91
sending, receiving and deleting 

multiple designs 91
writing single designs 91

Match to Palette tool 37, 101
measurement units, setting 14
Measuring Tape command 14

memory cards 4, 90
modifying designs

with the Color-Object List 43
modifying objects

flipping 62
grouping 59
locking 59
rotating 61
scaling 60

monitor, calibrating 7
Monogramming dialog

Lettering 73
Monogramming tool 72–73, 102
monograms

lettering with initials 72
mouse wheel, preset behavior 19
moving objects

nudging 58
positioning with X:Y 

coordinates 59
with click and drag 58

multi-hooped designs
outputting 94
saving as 96
sending to machine 95

multihooping, alignment marks 25
multiple designs

sending to machine 91

N
names, monogram lettering 73
Native Design files 89
native formats 89
new designs, creating 10
New tool 10, 101
non-outlined images 36
nudging objects 58

O
Object Details

tool 101
object details

changing 44
Object Details dialog

Dimensions tab 59, 60
Fill Stitch tab 49, 50, 77
Lettering tab 68, 70, 78
Line Stitch tab 47
Parallel Fill tab 45

object details, changing 44
Object Not Covered dialog 95, 97
objects

arranging 58
changing colors 45
cloning 55
combining 53
copying and pasting 54

deleting 55
duplicating 55
editing lettering 76
flipping 62
grouping 59
locking and unlocking 59
moving 58
resequencing 53
rotating 61
scaling 60
transforming 58
ungrouping 59

Open
dialog 10
tool 10, 101

open stitching, Travel on Edge 49
opening designs 10
orientations

circular 70
custom 71
horizontal 70
lettering 69
vertical 70

orientations, horizontal 
fixed-length 70

outline files 89
outlines

digitizing 39
selecting objects with 43

P
palette colors, match to image 37
panning designs 28
Parallel Fill

open stitching 49
Travel on Edge 49

Paste tool 36, 54, 101
pasting objects 54
patterns

printing appliqué 84, 86
selecting embossed fills 50
Weave Fill 48

PC memory cards 4, 90
PCMCIA cards 4, 90
peripheral devices

connection settings 3
setting up 1
See also hardware

pictures, see backdrops
popup menus 11
positioning objects 58
preview

designs 10
printed design 81

Print Options dialog 82–85
Print Preview

dialog 81
tool 81, 84, 85, 86

Print Preview tool 32, 101
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Print tool 81, 101
printing

designs 81, 82, 90
embroidery elements 83
Hoop option 83

Processed Stitches files 89

R
receiving designs 90
recoloring objects 45
Redo tool 11, 101
redoing commands 11
redrawing designs 30
registration marks, 

multihooping 25
Resequence List 56
Resequence tool 43, 56, 101
resequencing

by color 56
objects 53

Rotate CCW/CW tool 61, 101
Rotate Hoop 90° CCW / CW tool 23
Rotate Hoop tool 24, 102
rotating

objects 61
objects by click & drag 61
objects by Rotate CCW/CW 61

Run Line
stitch length 46
stitch type 46

S
Satin, digitizing borders 47
Save As dialog 19, 89
Save Options dialog 89
save options, automatic 19
Save tool 18, 96, 101
saving designs 18, 89
scaling

lettering 77, 78, 79
objects 60

scaling objects
by click & drag 60
on-screen 60
to an exact size 60
using Object Details 60

scanning
artwork 35
images 35

Screen Calibration dialog 7
scrolling, set automatic scrolling 19
Select

by Color dialog 27
Select Symbol dialog 69
Select tool 42, 55, 78, 79, 101
selecting objects

bounding outline 43
consecutive 43
grouping 59
point and click 42
with the Color-Object List 43

selection handles, rotating 61
Send to Machine tool 90, 93, 94, 95, 

101
sending designs 90
Set Color command 17
Setup menu

Work Environment 19, 56
Work Environment > Display 16, 

17
SEW format 89
shortcuts, keyboard 102
single designs, writing to ATA 

card 92
size

Embossed Fill 50
measuring designs 14

skewing objects
by click and drag 62
with rotation handles 62

Slow Redraw
dialog 30
tool 30, 102

spacing
grid 21
open spacing 49
Weave Fill stitches 48

special characters, selecting 69
Standard toolbar

Copy 54, 101
Cut 101
New 10, 101
Open 10, 101
Paste 36, 54, 101
Print 81, 101
Print Preview 32, 81, 84, 85, 86, 101
Redo 11, 101
Save 18, 96, 101
Send to Machine 90, 94, 95, 101
Stop 101
Undo 11, 101
Write to External Media 92, 96, 101

stitch angles
Embossed Fill 51

stitch files 89
supported formats 104

stitch length
Run 46

stitch spacing
Weave Fill 48

stitch types
applying to lettering 77
Run 46

stitch values
angle (Embossed Fill) 51
Embossed Fill 50
size (Embossed Fill) 50
Weave Fill 48

Stop tool 101
styles, monogram lettering 72
symbols, selecting 69
system preferences

automatic backup 19
automatic save 19

T
Thread Colors dialog 18
thread palettes, setting up 17
toolbars

Edit toolbar 101, 102
list of all toolbars 101
selecting commands 11
showing 11

tools
list of all tools 101, 103
showing toolbars 11

transforming
lettering 79
objects 58

Travel on Edge effect 49
traveling

by color 30

U
Undo tool 11, 101
undoing commands 11
ungrouping objects 59
Unlock command 59
unlocking

backdrops 59
objects 59

V
vector formats, supported 105
vertical orientations 70
View menu

Display Hoop 12
Measuring Tape 14
Zoom Whole Design 28
Zoom Whole Hoop 28

View toolbar
Design Measurement System 14, 

102
Display Grid 12, 21, 102
Display Hoop 102
Display Images 31, 102
Display Rulers and Guides 13, 21
Display Vectors 31, 102
Slow Redraw 30, 102
Visualizer 29, 102
Zoom Box 28, 102
Zoom In 28, 102
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Zoom Out 28, 102
viewing

design information 31
images 31
modes 27
objects by color 30

viewing designs 27
display options 29
displaying hidden objects 43
panning 28
redrawing slowly 30
selected parts only 29
Visualizer 29
zooming 28

Visualizer
tool 29, 102
viewing in 29

W
Weave Fill values 48
Work Environment

command 16, 19, 56
dialog 22
dialog > Autosave tab 19
dialog > Display tab 16, 17
dialog, Autosave tab 56
Display 56
Display tab 21
Scrolling 19

Work Environment > Edit dialog 56
Write to External Media tool 92, 96, 

101

X
X and Y coordinates, setting for 

objects 59

Z
Zoom Box tool 28, 102
Zoom In tool 28, 102
zoom in/out 28
Zoom Out tool 28, 102
Zoom Whole Design command 28
Zoom Whole Hoop command 28


	System Setup
	Installation checklist
	System requirements for Digitizer EXjr
	System security
	Modifying an existing Digitizer EXjr installation
	Connecting to your machine
	Supported machine models and memory cards
	Linking your PC by USB cable

	Installing USB drivers for direct machine connection
	Installing drivers for Windows XP
	Installing drivers for MS Windows® Vista/7

	Calibrating the monitor

	Basics
	Basic Procedures
	Getting started
	Starting Digitizer EXjr
	Opening designs
	Creating new designs

	Using commands
	Selecting commands from toolbars
	Showing or hiding toolbars
	Using popup menus
	Undoing & redoing commands

	Selecting machine models
	Displaying hoops & grids
	Displaying the hoop
	Displaying the grid
	Displaying rulers & guides
	Measuring distances on screen
	Setting measurement units

	Changing fabrics & backgrounds
	Changing fabric settings
	Changing background colors
	Changing background fabrics
	Mixing your own background color

	Setting up color palettes
	Saving designs
	Saving current design
	Setting automatic save options

	Setting scrolling options

	Grids & Hoops
	Adjusting grid and guide settings
	.Selecting hoops
	Changing hoops
	Centering hoops
	Rotating hoops

	Hooping large designs
	Creating a multi-hooping sequence
	Outputting alignment marks


	Viewing Designs
	Viewing design elements
	Viewing parts of a design
	Zooming & panning designs

	Design viewing modes
	Viewing designs with Visualizer
	Viewing connectors

	Traveling through designs
	Traveling by color
	Simulating design stitchout

	Viewing & hiding images
	Viewing design information
	Viewing design details
	Previewing design printouts



	Digitizing Essentials
	Digitizing with Artwork
	Choosing suitable artwork
	Importing images into Digitizer EXjr
	Inserting images
	Copying & pasting images
	Preparing images for digitizing

	Digitizing images with Click-to-Stitch
	Matching palette colors to an image
	Digitizing fills with Click-to-Stitch
	Digitizing outlines with Click-to-Stitch

	Digitizing images with Click-to-Design

	Editing Objects
	Object types
	Selecting objects in designs
	Selecting all objects in a design
	Selecting objects by point and click
	Selecting objects with a bounding box
	Selecting a range of objects by point and click
	Viewing and selecting colors

	Changing object details
	Changing details of selected objects
	Changing Parallel Fill details

	Changing colors of selected objects
	Changing line stitch details
	Changing line stitch type
	Setting Run Line stitch length
	Setting Satin Line width and density

	Changing Satin Fill details
	Changing Weave Fill details
	Selecting Weave Fill patterns
	Adjusting Weave Fill details
	Creating open weave effects

	Changing Embossed Fill details
	Selecting Embossed Fill patterns
	Adjusting Embossed Fill size and spacing
	Adjusting Embossed Fill stitch angle



	Modifying Designs
	Combining & Sequencing Objects
	Inserting designs
	Duplicating & cloning objects
	Copying & pasting objects
	Duplicating objects
	Cloning objects
	Deleting objects
	Setting duplication options

	Resequencing designs by color

	Arranging & Transforming Objects
	Positioning objects
	Positioning objects on screen
	Positioning objects via settings

	Locking & grouping objects
	Locking objects
	Grouping objects
	Ungrouping objects

	Scaling objects
	Scaling objects on screen
	Scaling objects via settings

	Rotating objects
	Rotating objects on screen
	Rotating objects using Rotate

	Skewing objects
	Flipping objects
	Creating ornamental layouts
	Defining work areas
	Creating layouts



	Embroidery Lettering
	Creating Embroidery Lettering
	Adding lettering to embroidery designs
	Creating embroidery lettering
	Adding special characters

	Setting lettering orientations
	Selecting lettering orientation
	Creating horizontal orientations
	Creating vertical orientations
	Creating circular orientations
	Creating custom orientations

	Creating monogram lettering
	Creating monogram lettering with initials
	Creating monogram lettering with names


	Editing Embroidery Lettering
	Editing lettering
	Changing lettering stitch types
	Scaling lettering
	Scaling lettering on screen
	Scaling lettering via settings

	Transforming lettering


	Design Processing
	Printing Designs
	Previewing printouts
	Setting print options
	Printing design elements
	Printing design layouts
	Printing color layers
	Printing appliqué patterns
	Printing multi-hooped designs

	Reading & Writing Design Files
	Embroidery design formats
	Saving designs for machine
	Sending & writing designs
	Direct connection
	Supported storage devices

	Sending designs to machine
	Writing to external media
	Sending designs with multi-position hoops
	Sending designs with an MA Hoop
	Sending designs with a Giga Hoop

	Outputting multi-hooped designs
	Sending multi-hooped designs to machine
	Saving multi-hooped designs



	Appendices, Glossary & Index
	Quick Reference
	Digitizer EXjr Design Window
	Tools and toolbars
	Standard toolbar
	Digitize toolbar
	Docker toolbar
	Edit toolbar
	Easy Layout toolbar
	Combine toolbar
	Lettering toolbar
	View toolbar

	Keyboard shortcuts

	Supported Files & Hoops
	Supported embroidery file formats
	Supported electronic artwork formats
	Supported hoop types

	Packaged Fonts
	Standard fonts
	Monogramming fonts
	Fancy Monogram
	Octagon Monogram
	Point Monogram
	Seal Monogram



	Index

